Troubleshooting
Problem
Events might show a status of "Uncertain". This technote explains why this happens.
Cause
Working as designed
Diagnosing The Problem
Issue the QUERY EVENT administrative command to display events. For example:
tsm: MYSERVER>q event * * begind=-30 endd=today
Scheduled Start Actual Start Schedule Name Node Name Status
-------------------- -------------------- ------------- ------------- ---------
08/01/2010 19:00:00 DAILY_SCHED MYNODE Uncertain
08/02/2010 19:00:00 DAILY_SCHED MYNODE Uncertain
08/03/2010 19:00:00 DAILY_SCHED MYNODE Uncertain
08/04/2010 19:00:00 DAILY_SCHED MYNODE Uncertain
Issue the QUERY STATUS administrative command to verify the event record retention. For example:
tsm: MYSERVER>q status f=d
...
Event Record Retention Period: 10 Day(s)
In this case, event records are kept for 10 days. Any event record older than 10 days or any event record deleted using the DELETE EVENT administrative command will report an "Uncertain" status.
Resolving The Problem
The "Uncertain" status is defined under the QUERY EVENTS administrative command in the Administrator's Reference manual as follows :
Specifies that the state of the event cannot be determined. The server specifies Uncertain if the QUERY EVENT command does not find an event record. An event record will not be found if the record was deleted or if the server was unavailable during the scheduled startup window (the schedule was never started). Records with Uncertain status do not reside in the database. If you do not want these records to display, either specify EXCEPTIONSONLY=YES or delete the schedule if it is no longer needed.
In other words, it is normal for "deleted" events to be reported as "Uncertain". The "Uncertain" status will continue to be reported as long as the schedule exists or is updated. After a schedule is updated, the server does not report any past schedules results anymore. This is also documented under the QUERY EVENTS administrative command in the Administrator's Reference manual. Specifically, it is mentioned that "if a client schedule is changed, all previous event records for that schedule are removed from the database".
If you do not need the past schedule events, you can update the schedule using the UPDATE SCHEDULE administrative command and all past schedule events, including the "Uncertain" ones, will no longer be reported.
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Document Information
Modified date:
17 June 2018
UID
swg21444582