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QUERY DRIVE shows an UNKNOWN device type

Troubleshooting


Problem

A Tivoli Storage Manager server has a new library and drives defined at a Disaster Recovery site. Drives show an unknown device type. When a client attempts to restore data from a tape in the new library, the operation fails with the ANR0567W error.

Cause

The path to the drive is incorrectly defined. An incorrect source name was specified on the DEFINE PATH command.

Diagnosing The Problem

The QUERY DRIVE command shows UNKNOWN for the drive device type. For example:

tsm: MYSERVER1>q drive f=d
Library Name: LIB1
Drive Name: DRIVE1
Device Type: UNKNOWN

A client restore fails with the following error:

ANR0567W Retrieve or restored failed for session session number for node node name (client platform) - insufficient mount points available to satisfy the request.

Resolving The Problem

In this case, the drive Device Type is set to UNKNOWN because the drive path was defined using a source name that did not match the name of the Tivoli Storage Manager server. To correct this problem, follow these steps:

  1. Delete the drive and its path using the DELETE PATH and DELETE DRIVE commands.
  2. Run the QUERY STATUS command to verify the server name. For example:

    tsm: MYSERVER1>q status
    Server Name: MYSERVER1

    In this case, the name of the server is MYSERVER1
  3. Run the DEFINE DRIVE command to define the drive to the library.
  4. Run the DEFINE PATH command and define a path to the drive using the same "Server Name" in the Source Name parameter. For example:

    define path MYSERVER1 DRIVE1 srctype=server destt=drive library=LIB1 device=xxx
  5. Run the QUERY DRIVE command to verify the device type of the drive. For example:

    tsm: MYSERVER1>q drive f=d
    Library Name: LIB1
    Drive Name: DRIVE1
    Device Type: LTO
[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Supported Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

More support for:
Tivoli Storage Manager

Software version:
All Supported Versions

Document number:
139949

Modified date:
17 June 2018

UID

swg21440635