Troubleshooting
Problem
Date-based queries that were created with Rational ClearQuest for Windows client, (version 7.1.1.0, 7.1.1.1, 7.1.1.2, 7.1.1.3, 7.1.1.4, 7.1.2.0, or 7.1.2.1) are incorrectly converted in the ClearQuest Web client which might cause an error to be displayed when they are executed.
Symptom
When you execute these queries in ClearQuest 7.1.2.x Web, the results are either invalid--based on an unexpected date far in the past--, or you receive the following error message:
CRVSV0078E Error from RPC server: CRVSV0789E The executing query failed:
CRVSV0078E Error from RPC server: CRVSV0789E The executing query failed:
If you review the query definition from CQ Web, you will notice that the dates were converted incorrectly and have very old dates:
Cause
This issue was identified as a product defect under APAR PM19849.
Resolving The Problem
This problem is fixed starting in ClearQuest 7.1.1.5 and 7.1.2.2.
To permanently resolve instances of this query issue in earlier versions of the ClearQuest Client for Windows, recreate or modify the query that is causing an error message or generating an incorrect result set.
- In any version of the ClearQuest Eclipse client or the ClearQuest Web Client, edit the query.
- Click on the date/time filter to update the format of the date/time filter.
You do not need to change anything. Clicking the date/time filter flags the query as changed. - Save the query to update the date/time portion of the query with the correct format.
- Run the query to verify that it produces correct results.
If users wish to continue using the ClearQuest Client for Windows, these hosts must be upgraded to at least versions 7.1.1.5 or 7.1.2.2. All new queries created or modified with ClearQuest versions 7.1.1.5 or 7.1.2.2 or newer will work as expected in all clients.
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Document Information
Modified date:
14 January 2020
UID
swg21497071