Troubleshooting
Problem
QRadar relies on geolocation data from
/opt/qradar/conf/geodata.conf, while MaxMind tags IPs by country. If the data from MaxMind and QRadar's geodata file do not match, rules using geolocation may trigger incorrectly. This happens because QRadar prioritizes its local geodata file over MaxMind's data.Symptom
Working with geolocation in rules can lead to false positives.
Cause
The
/opt/qradar/conf/geodata.conf file needs to be updated with the correct information.Diagnosing The Problem
To diagnose the problem, administrators can run the following steps:
- Use SSH to log in to the QRadar Console as the root user.
- Search for a subnet definition on the geodata.conf file:
Note: Replace <subnet_definition> with a real value.grep '<subnet_definition>' /opt/qradar/conf/geodata.confExample:[root@console ~]# grep '23.33.200.0' /opt/qradar/conf/geodata.conf Europe Germany 23.33.200.0/22 50 DE - Search for the same subnet on IBM X-Force Exchange:
Note: The IPv4 23.33.200.0 is being used as an example.

- Compare the location values from step 2 and step 3.
Result
The administrator has found a mismatch between the geolocation data from geodata.conf and X-Force Exchange.
Resolving The Problem
To workaround the problem, administrators can run the following steps:
- Log In to the QRadar WebUI as an Admin user.
- Click the Admin tab from the navigation bar.
- Click Network Hierarchy from the System Configuration section.
- A new window is open, click on the Add button:

- Fill in the information and click on the Create button.

- Deploy the changes.
Result
The system recognizes the IP based on how it is configured in the Network Hierarchy section. If the issue persists, contact QRadar Support for assistance.
Document Location
Worldwide
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Document Information
Modified date:
06 December 2024
UID
ibm17177550