IBM Support

QRadar: "Cannot get device ring settings: Operation not supported" while installing or using qchange_netsetup

Troubleshooting


Problem

Administrators who are either installing QRadar or using qchange_netsetup receive an error about device ring settings. This error typically occurs when the interface selected during an install or address update does not have an active link.

Symptom

While installing QRadar, or using qchange_netsetup to change network settings, administrators can receive the following error:
"Cannot get device ring settings: Operation not supported"

Cause

The selected interface is not an active link.

Resolving The Problem

The administrator must select an active link, indicated by a "+" sign beside the link.  
For example:
image-20240315152738-1

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSBQAC","label":"IBM Security QRadar SIEM"},"ARM Category":[{"code":"a8m0z000000cwszAAA","label":"Install"}],"ARM Case Number":"TS015338043","Platform":[{"code":"PF016","label":"Linux"}],"Version":"All Versions"}]

Document Information

Modified date:
20 March 2024

UID

ibm17130051