IBM Support

Problem logging in as root account on Broadcom switch

Troubleshooting


Problem

Unable to login to Broadcom switch as "root" user

Symptom

While trying to login to Broadcom switch as root user.
Different errors can be seen like.
root account is disabled
root access not allowed
Access for this account on this interface is disabled; please contact your system administrator

Cause

Root access is no longer permitted starting with FOS version 9.1. At this firmware level and above, root login is disabled by design.

For earlier versions such as FOS 9.0, 8.x, and 7.x, root access may either be disabled entirely or restricted to console access only, depending on the switch configuration.

 

Resolving The Problem

Enabling root access on Brocade FOS 9.0 and lower

Follow the steps below to verify and configure root access on a Brocade switch running FOS 9.0.

1. Verify Current Status of the root account

From an admin-level account, run the following command:

IBM_switch:admin> userconfig --show root

Sample output:

Account name: root*
Description: root
Enabled: No    *** Root user is currently disabled ***
Password Last Change Date: Unknown (UTC)
Password Expiration Date: Not Applicable (UTC)
Locked: No
Role: root
Day Time Access: N/A
REST Auth Token: No
  
Note: If Enabled is set to No, the root account is currently disabled.


2. Enable the root account (If disabled)

To enable the root account, execute:

IBM_switch:admin> userconfig --change root -e yes


3. Verify root access scope

Check the current root access level using:

IBM_switch:admin> rootaccess --show

Sample output:

RootAccess: consoleonly

The possible root access levels are:

  • none – Disables root login from all interfaces.
  • consoleonly – Allows root login only through the serial console (default).
  • all – Allows root login through all supported interfaces (console, SSH, etc.).


4. Modify root access scope 

To allow root login from all interfaces, run:

IBM_switch:admin> rootaccess --set all

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB26","label":"Storage"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"STQPQQ","label":"IBM System Networking SAN128B-6"},"ARM Category":[{"code":"a8m0z000000bqNkAAI","label":"Brocade IBM B-Type-\u003EProblems"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}]}]

Document Information

Modified date:
28 October 2025

UID

ibm16832140