Troubleshooting
Problem
Users are having issues with printing PDFs that are coming from Content Navigator and are being viewed through ViewONE Virtual in Google Chrome. The users need to a have the setting to download PDF files instead of automatically opening them in Chrome set to on. When this setting is on, the users cannot print PDFs from ViewONE Virtual.
Symptom
Everything stops after the File Preparation Complete screen - click on the "OK" button but after this, the browser print dialog never appears so the print operation cannot be completed.
Cause
The way printing works in Daeja ViewONE Virtual is a two stage process:
1) Initially a PDF file is generated on the server (this is the "prepare file" process)
2) This PDF is then sent direct to the browser with some additional JavaScript that invokes the print process via the browsers PDF plug-in\viewer
With the setting "Download PDF files instead of automatically opening them in Chrome" enabled, this effectively disables the Java Script in the PDF file from running and invoking the PDF plug-in to complete the print process - so printing from Daeja ViewONE Virtual will not work with this setting and this is expected behaviour because of how the print process works.
1) Initially a PDF file is generated on the server (this is the "prepare file" process)
2) This PDF is then sent direct to the browser with some additional JavaScript that invokes the print process via the browsers PDF plug-in\viewer
With the setting "Download PDF files instead of automatically opening them in Chrome" enabled, this effectively disables the Java Script in the PDF file from running and invoking the PDF plug-in to complete the print process - so printing from Daeja ViewONE Virtual will not work with this setting and this is expected behaviour because of how the print process works.
Diagnosing The Problem
Toggle the setting for "Download PDF files instead of automatically opening them in Chrome" (accessed via Chrome Settings -> Advanced Settings -> Content Settings -> PDF documents section) to confirm that with download disabled, the printing works as expected.
Resolving The Problem
Ensure that the setting for Download PDF files instead of automatically opening them in Chrome" is disabled.
Document Location
Worldwide
[{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSTTN8","label":"IBM Daeja ViewONE Virtual"},"Component":"Virtual","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF043","label":"Red Hat"},{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"4.1.5.X,5.0.X","Line of Business":{"code":"LOB45","label":"Automation"}}]
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Document Information
Modified date:
28 January 2021
UID
ibm10870934