Troubleshooting
Problem
Sharing violation can occur when an application opens a file while CDP for Files is backing it up.
Symptom
After a file is modified and closed, CDP queues up the backup to the local, remote, or remote scheduled backup queues. When the file's entry in the queue is processed, CDP will open the file and start backing it up. During the file backup, some applications will re-open the file while CDP is backing that file up resulting in an error. Under normal circumstances this does not cause a problem, however sometimes the sharing flags the application uses to re-open the file are not compatible with the flags that CDP uses to open the file. This results in the application receiving an error from the open function, which will typically return one of the following Microsoft Windows error codes:
| Error # | Message Text | Message Identifier |
| 32 | The process cannot access the file because it is being used by another process. | ERROR_SHARING_VIOLATION |
| 0xC0000043 | A file cannot be opened because the share access flags are incompatible. | STATUS_SHARING_VIOLATION |
| 13 | Permission denied. | EACCES |
After receiving these errors some applications may retry the open until the error is not returned or they may retry the open with compatible sharing flags, such applications will succeed and not have any issues.
Other applications do not handle this error and fail. The way such an application expresses the error may differ from application to application.
There are only 2 known applications that CDP interferes with:
- Quickbooks
Microsoft Windows Explorer's Compressed Folders (.zip) feature
Cause
CDP for Files backup can, under rare circumstances, interfere with an application's access to its file.
Diagnosing The Problem
Different applications will show this problem in different ways. See the chart in the "Symptom" section for possible error messages.
Resolving The Problem
There are some work-arounds that can be applied depending on the backup needs and the behavior of the application involved.
1. If the problem happens when the application creates a temporary file in a directory that is included for remote continuous backup and that file has a particular pattern, then add that pattern to the exclude list. This pattern will be application specific. If the application's temporary file does not follow a specific pattern that can be easily excluded, then instead of including the entire directory include only those file extensions that you wish to backup.
2. If the problem happens when the application is accessing one of its files in a directory that is included for remote continuous backup, then set up CDP so that that type of file is backed up using scheduled backup.
3. You may be able to pause CDP for files before working with the application that experiences this problem.
4. If the application does not work in a directory that CDP has included for remote continuous backup, consider using an excluded directory for those applications files and then copying those files over to a directory that CDP has included for remote continuous backup when they need to be backed up.
Related Information
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Document Information
Modified date:
23 June 2018
UID
swg21411522