Troubleshooting
Problem
Portlets that include TIP charts in the Tivoli Integrated Portal seem to hang and eventually return the error "TIPCH0006E read timeout"
Cause
The connection to the chart datasource has exceeded configured timeout parameter
Diagnosing The Problem
Enable TIP traces including TIP Chart trace using the directions in the following technical note:
"Enabling tracing for Tivoli Integrated Portal"
https://www-304.ibm.com/support/docview.wss?uid=swg21437655
Review the trace.log for errors like:
#####
[6/8/12 11:54:35:851 EDT] 00000022 SystemErr R java.lang.Exception: TIPCH0006E An error occurred while collecting data for the chart, check the web service data source.
.
.
.
Caused by: org.eclipse.datatools.connectivity.oda.OdaException ;
org.apache.axis2.AxisFault: Read timed out
.
.
.
######
Resolving The Problem
Use the following instructions to increase the timeout value for the TIP Charts datasource connection:
For TIP 1.x:
The axis time out can be modified by following the below steps:
1. Stop TIP server
2. Navigate to <TIPHOME>/properties/
3. Edit charts.properties
4. The following entry in the charts.properties needs to be updated
AXIS_TIMEOUT=90000
By default it will be set to 1.5 minutes, Please change it to 3 minutes
AXIS_TIMEOUT-180000
For TIP 2.x:
Running the below command from $TIPHOME/profiles/TIPProfile/bin
./tipcli.sh ChartProperties --username tipadmin --password <password for tipadmin> --name AXIS_TIMEOUT --value <value in milliseconds>
Was this topic helpful?
Document Information
Modified date:
17 June 2018
UID
swg21598214