Troubleshooting
Problem
After migrating the TM1 application to new servers, users are unable to open their workbooks in Cognos Analysis for Microsoft Excel. The below error pops-up on the Excel session. The var pmhubURLs in the pmhub.html are accurate.
Symptom
The pmhub service parameter was not specified or is not one of the configured locations
Cause
Pre-existing workbooks which have the previous server information embedded.
Diagnosing The Problem
Test creating a new workbook in Cognos Analysis for Microsoft Excel using the new environment connection. If that is successful, then the application is working and the issue is only with saved workbook.
Resolving The Problem
Run the Update System Utility on the workbook(s) affected and save the changes when the process is complete.
In Excel, while connected to IBM Cognos and accessing a save workbook:
- select Options in the IBM Cognos Ribbon
- scroll down to the bottom and select Update System Utility
- on the Update System popup screen, select the old system first and the new second, click OK
- you may be prompted to logon
- when the process is complete, save your workbook
The next time you access the workbook using the new server connection, it will update accordingly, without the above error message.
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Document Information
Modified date:
15 June 2018
UID
swg22001247