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Planning Analytics on Cloud federated logon - An error has occurred FBTSML225E Token exchange failed

Troubleshooting


Problem

A PA Cloud customer is onboarding new users. On accepting their email invitation, instead of being able to log in they get an error.
The issue may be affecting some users and not others.

Symptom

Example of the error:
An error has occurred
FBTSML225E Token exchange failed.
Time:
2019-03-07 14:23:56
Request address:
/mtfim/sps/idaas/saml20/login
Error details:
FBTSTS001E The given SAML assertion is not valid yet.
Please contact our help desk to report this issue.

Cause

When a user logs in with Federation, a SAML exchange takes place between the IBM authentication (IBM ID) and the customer organisations own Active Directory (AD) where the same user is a member.
If an element of the users information in the Active Directory is incorrect, an error may occur.

Environment

Planning Analytics on Cloud - Federated access with SAML exchange to log in with IBM ID

Diagnosing The Problem

Check the users AD entry. Is for example the Country Code wrong?

Resolving The Problem

Correct the country code associated with the AD user.

Document Location

Worldwide

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Document Information

Modified date:
20 September 2021

UID

ibm10884690