Troubleshooting
Problem
When running the IBM Content Collector P8 Repository Configuration Tool to create ICCMail3 class as part of the email data migration process, the tool will attempt to create an index for the ICCMailReference property. Depending on the size of the Content Engine database, this may take several minutes and exceed the default transaction timeout value set in Websphere.
Symptom
The following error message may be seen in the initial configuration log file.
For example:C:\IBM\ContentCollector\Configuration\initialConfig\log\AfuInitialConfigTrace.log
2015-07-08T20:05:22.889Z INFO [855] OUTPUT>A P8CE error has occurred -> E_TRANSACTION_FAILURE : A transaction problem has occurred. :
ExceptionCode=E_TRANSACTION_FAILURE Id=FNRCE0075
Class=FileNet.Api.Exception.ErrorRecord
Source=com.filenet.api.exception.EngineRuntimeException Description=A
transaction problem has occurred. stackTrace=at
com.filenet.engine.ejb.EJBUtil.determineException(EJBUtil.java:113)
[com.ibm.afu.initialconfig.helper.ExecuteOutputReader run] [Thread-21 8]
Cause
The time taken to create the index exceeds the default transaction timeout set in Websphere.
Environment
IBM Content Collector, P8 FileNet Content Engine with Websphere
Resolving The Problem
To resolve this issue:
- Log on to Websphere administrative console for your P8 FileNet Content Engine server.
- Navigate to Servers > Server Types > WebSphere application servers > server 1 > [Container Settings] Container Services > Transaction Service, where server 1 stands for the server where FileNet Content Engine application is running.
- On the Configuration tab, increase the values of:
- Maximum transaction timeout
- Total transaction lifetime timeout
- Click Apply and then click Save. Restart the server.
- Rerun the P8 Repository Configuration Tool. The tool should be able to successfully complete.
- Change the values back and save in Websphere administrative console.
Related Information
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Document Information
Modified date:
17 June 2018
UID
swg21961910