IBM Support

Overview - IBM Spectrum Protect Supported Operating Systems

Question & Answer


Question

Which operating system levels are supported by the IBM Spectrum Protect™ server and IBM Spectrum Protect backup-archive client?

Answer

For system requirements for previous product versions, see Overview - Tivoli Storage Manager Supported Operating Systems. It provides information about the following releases:

  • Tivoli Storage Manager server 6.4 and 7.1 releases
  • Tivoli Storage Manager backup-archive client 6.4 and 7.1 releases

Note: IBM Spectrum Protect and IBM Tivoli Storage Manager 7.1 reached end of support (EOS) at 31 December 2021. See also IBM Spectrum Protect and Tivoli Storage Manager 7.1 products End of Support 31 December 2021

Server operating systems Backup-archive client operating systems
AIX
Linux x86_64
Linux on Power Systems (little endian)
Linux zSeries
Windows
AIX
HP-UX Itanium
Linux on POWER
Linux on POWER LE
Linux x86_64
Linux zSeries
Macintosh
Solaris SPARC
Solaris x86_64
Windows
Storage agent requirements Operations Center requirements
For IBM Spectrum Protect storage agent requirements, click here For IBM Spectrum Protect Operations Center requirements, click here
 


 

The following table provides an overview of the operating system levels are supported by the IBM Spectrum Protect backup-archive client. For the most current details about each component's operating system support, including hardware requirements, click the operating system name in the Operating system column.

To determine which IBM Spectrum Protect backup-archive client to use when planning to upgrade, see IBM Spectrum Protect Downloads - Latest fix packs and interim fixes

The IBM Spectrum Protect server administrator can automatically deploy a backup-archive client to update workstations where the backup-archive client is already installed. For more information, see Automatic backup-archive client deployment. 
Note: all backup-archive clients listed in the following table can be also automatically deployed.

Operating system

Click the name in the table for detailed requirements
IBM Spectrum Protect backup-archive client

Release 8.1
Latest fix pack 8.1.13
IBM Spectrum Protect backup-archive client

Release 7.1
Latest fix pack 7.1.8
AIX -- AIX V6.1 (Supported in 7.1.0 - 7.1.8.9)
AIX 7.1 TL0-TL3 (Supported in 8.1.0 - 8.1.10)
AIX 7.1 TL4 or later fix pack levels

Note: As in APAR IT35286: Because of security fixes, the operating levels AIX 7.1 TL0-TL3 (xlc.rte < 13.0) are not longer supported by IBM Spectrum Protect backup-archive client 8.1.11 and later levels.
 AIX 7.1 TL0-TL3 (Supported in 7.1.0 - 7.1.8.9)
 AIX 7.1 TL4 or later fix pack levels*

Note: As in APAR IT35286: Because of security fixes, the operating systems AIX 6.1 and AIX 7.1 TL0-TL3 (xlc.rte < 13.0) are not longer supported by IBM Spectrum Protect backup-archive client 7.1.8.10 and later levels.
AIX 7.2 or later fix-pack levels (64-bit kernel) AIX 7.2 64-bit kernel (Beginning with 7.1.4.4)
Note:  AIX levels plus required minimum level of xlC.rte and xlsmp.rte file sets Note: AIX levels plus required minimum level of xlC.rte and xlsmp.rte file sets
HP-UX Itanium HP-UX 11i V3 for Itanium 2 64-bit

Note: For 8.1, only the HP-UX IA-64 Itanium API is delivered.
HP-UX 11i V3
Linux on POWER SUSE Linux Enterprise Server 11 (64 bit) (1) SLES 11 (64 bit)(1)
-- RHEL 5 (64 bit)(1)
Red Hat Enterprise Linux 6 (64 bit)(1) RHEL 6 (64 bit)(1)
Red Hat Enterprise Linux 7 (64 bit)(1) RHEL 7 (64-bit)(1) (Beginning with 7.1.1 client)
Note: For 8.1, only the Linux on Power big endian API is delivered. --
(1) Later maintenance levels and service packs are also supported. See left column
Linux on POWER LE SUSE Linux Enterprise Server 12 (64 bit)(2) SLES 12 (64 bit)(2)
(Beginning with API 7.1.2 and backup-archive client 7.1.4)
SUSE Linux Enterprise Server 15 (64-bit)(2) (Beginning with 8.1.6) --
Red Hat Enterprise Linux 7 (64 bit)(2)

Note: IBM Spectrum Protect backup-archive client support for Linux on Power Little Endian started with RHEL 7.1.
RHEL 7.1 (64-bit)(2)
(Beginning with API 7.1.2 and backup-archive client 7.1.4)
Red Hat Enterprise Linux 8 (64 bit)(2) (Beginning with 8.1.9) --
(2)Later maintenance levels and service packs are also supported. See left column
Attention: The operating system kernel in Red Hat Enterprise Linux (RHEL) versions 7.8 and 8.2 is incompatible with the IBM Spectrum Protect backup-archive client journal-based backup kernel extension. This issue is fixed in the backup-archive client  7.1.8.9 and 8.1.11 on all Linux platforms, see APAR IT33132 See left column
Ubuntu 14.04 LTS Ubuntu 14.04 (64 bit)
(Beginning with API 7.1.2 and backup-archive client 7.1.4.4)
Ubuntu 16.04 LTS Ubuntu 16.04 (64 bit) (Beginning with 7.1.6.3)
Ubuntu 18.04 LTS (Beginning with 8.1.6) --
Ubuntu 20.04 LTS
(Beginning with backup-archive client 8.1.10)
--
Linux x86_64 SUSE Linux Enterprise Server 11 (64-bit) (3)
SUSE Linux Enterprise Desktop 11 (64-bit)(3)
SLES 11 (64 bit)(3)
SLED 11 (64 bit)(3)
SUSE Linux Enterprise Server 12 (64-bit)(3) SLES 12 (64 bit)(3) (Beginning with 7.1.2 client)
SUSE Linux Enterprise Server 15 (64-bit)(3) (Beginning with 8.1.6) --
-- RHEL 5 (64 bit)(3)
Red Hat Enterprise Linux 6 (64-bit)(3) RHEL 6 (64 bit)(3)
Red Hat Enterprise Linux 7 (64-bit)(3) RHEL 7 (64 bit)(3) (Beginning with 7.1.1)
Red Hat Enterprise Linux 8 (64-bit)(3) (Beginning with 8.1.9) --
(3)Later maintenance levels and service packs are also supported. See left column
Attention: The operating system kernel in Red Hat Enterprise Linux (RHEL) versions 7.8 and 8.2 is incompatible with the IBM Spectrum Protect backup-archive client journal-based backup kernel extension. This issue is fixed in the backup-archive client  7.1.8.9 and 8.1.11 on all Linux platforms, see APAR IT33132 See left column
Note: Linux client distributions supported as a data mover with the Tivoli Storage Manager for Virtual Environments product are documented in links here.
Ubuntu 14.04 LTS Ubuntu 14.04 (Beginning with 7.1.2)
Ubuntu 16.04 LTS Ubuntu 16.04 (Beginning with 7.1.6.3)
Ubuntu 18.04 LTS (Beginning with 8.1.6) --
Ubuntu 20.04 LTS (Beginning with 8.1.10) --
Linux zSeries SUSE Linux Enterprise Server 11 (64-bit)(4) SLES 11 (64 bit)(4)
SUSE Linux Enterprise Server 12 (64-bit)(4) SLES 12 (64 bit)(4) (Beginning with 7.1.2)
SUSE Linux Enterprise Server 15 (64-bit)(4) (Beginning with 8.1.6) --
-- RHEL 5 (64 bit)(4)
Red Hat Enterprise Linux 6 (64-bit)(4) RHEL 6 (64 bit)(4)
Red Hat Enterprise Linux 7 (64-bit)(4) RHEL 7 (64 bit)(4) (Beginning with 7.1.1)
Red Hat Enterprise Linux 8 (64-bit)(4) (Beginning with 8.1.9) --
(4)Later maintenance levels and service packs are also supported. see left column
Attention: The operating system kernel in Red Hat Enterprise Linux (RHEL) versions 7.8 and 8.2 is incompatible with the IBM Spectrum Protect backup-archive client journal-based backup kernel extension. This issue is fixed in the backup-archive client 7.1.8.9 and 8.1.11 on all Linux platforms, see APAR IT33132 see left column
Macintosh Note: Apple silicon-based Macintosh, that uses translation mechanism Rosetta 2 is currently not supported. This web page will be updated with further details when support is available. --
macOS 12 (Monterey) (Beginning with 8.1.13) --
macOS 11 (Big Sur) (Beginning with 8.1.12) --
macOS 10.15 (Catalina) (Beginning with 8.1.9.1)

Note: Apple changes their Macintosh security model and requires that any software, which is running on their operating systems, is signed and notarized by Apple. Due of these changes, IBM Spectrum Protect backup-archive client 8.1.10 and later supports macOS 10.15.
--
macOS 10.14 (Mojave) (Beginning with 8.1.6)

Note: Apple changes their Macintosh security model and requires that any software, which is running on their operating systems, is signed and notarized by Apple. Due of these changes, IBM Spectrum Protect backup-archive client 8.1.10 and later supports macOS 10.14.

Note: Beginning with GSKit 8.0.55.17, GSKit provide 64 bit signed and notarized packages supporting macOS 10.14.5 and later. For that reason IBM Spectrum Protect backup-archive client 8.1.11 and later support started with macOS 10.14.5.
--
If you are using the following operating systems, use IBM Spectrum Protect backup-archive client 8.1.9:
  • OS X 10.11 (Beginning with 8.1.0)
  • macOS 10.12 (Beginning with 8.1.0)
  • macOS 10.13 (Beginning with 8.1.2)
Mac OS X 10.11 (Beginning with 7.1.3.2)
-- Mac OS X 10.10
(Beginning with 7.1.1)
-- Mac OS X 10.9
-- Mac OS X 10.8
Solaris SPARC Solaris 10 (64 bit) update 1 or later updates Solaris 10
Solaris 11 (64 bit) or later updates Solaris 11
Note: For 8.1, only the Oracle Solaris SPARC API is delivered. --
Solaris x86_64 Solaris 10 (64 bit) Solaris 10 (64-bit) (Beginning with 7.1.1)
Solaris 11 (64 bit) Solaris 11 (64-bit) (Beginning with 7.1.1)
Windows Note: For all x64 editions (with Automated System Recovery (ASR) for Extensible Firmware Interface (EFI) and non-EFI systems), see the limitations on the detailed requirements page. Note: For all x64 and x32 editions (with Automated System Recovery (ASR) for Extensible Firmware Interface (EFI) and non-EFI systems), see the limitations on the detailed requirements page.
-- Windows Server 2008, all x64 editions
-- Windows Server 2008 R2, all x64 editions
Windows Server 2012, all x64 editions Windows Server 2012, all x64 editions
Windows Server 2012 R2, all x64 editions Windows Server 2012 R2, all x64 editions
Windows 2016 Server(*), all x64 editions Windows 2016 Server(*), all x64 editions (Beginning with 7.1.8)
Windows 2019 Server(*), all x64 editions (Beginning with 8.1.7) --
Windows 2022 Server(*), all x64 editions (Beginning with 8.1.13) --
-- Windows 7, all x32, and x64 editions
-- Windows 8, all x32, and x64 editions
Windows 8.1, all x64 editions Windows 8.1, all x32, and x64 editions
Windows 10(*), all x64 editions except Mobile Windows 10(*), all x32, and x64 editions except Mobile (Beginning with 7.1.3.2)
Windows 11(*), all x64 editions except Mobile (Beginning with 8.1.13) --
(*) only Long-Term Servicing Channel (LTSC) products are supported. (*) only Long-Term Servicing Channel (LTSC) products are supported.
-- Note: Windows client operating system levels supported as a data mover with the Tivoli Storage Manager for Virtual Environments product are documented in links here.




 

Related Information

[{"Product":{"code":"SSEQVQ","label":"IBM Spectrum Protect"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"8.1","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}},{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
09 December 2021

UID

swg21243309