Troubleshooting
Problem
Out of memory errors can occur when the size of the heap for the Java™ Virtual Machine (JVM) is not large enough.
Cause
This type of error can occur when the size of the heap for the JVM is not large enough.
The heap is the amount of memory that the JVM running Business Integration Modeler is allowed to use. As the size of a model increases, the amount of memory it requires in the heap increases. When the model size exceeds the heap size, an out of memory error occurs.
The following table lists the optimal heap size for performance in a system with physical memory size as shown:
System memory (physical) | Optimal heap size |
512 MB | 256 MB |
1 GB | 512 MB |
1.5 GB | 768 MB |
2+ GB | 1024 MB |
Resolving The Problem
To change the JVM's heap size, complete the following steps:
1. Click Start.
2. Right-click on the WebSphere® Business Modeler shortcut in your Start menu and select Properties. The properties window for the shortcut appears.
3. Append the following to the command string in the Target field:
-vmargs -Xmx<number>M
Where <number> is the heap size in megabytes.
4. Click OK.
When you start WebSphere® Business Modeler, the JVM uses the heap size you specified.
Was this topic helpful?
Document Information
More support for:
WebSphere Business Modeler Advanced
Software version:
6.1, 6.0, 5.1.1
Operating system(s):
Windows
Document number:
81165
Modified date:
15 June 2018
UID
swg21193029