IBM Support

Out of memory errors caused by insufficient JVM heap

Troubleshooting


Problem

Out of memory errors can occur when the size of the heap for the Java™ Virtual Machine (JVM) is not large enough.

Cause

This type of error can occur when the size of the heap for the JVM is not large enough.

The heap is the amount of memory that the JVM running Business Integration Modeler is allowed to use. As the size of a model increases, the amount of memory it requires in the heap increases. When the model size exceeds the heap size, an out of memory error occurs.

The following table lists the optimal heap size for performance in a system with physical memory size as shown:

System memory (physical)
Optimal heap size
512 MB256 MB
1 GB512 MB
1.5 GB768 MB
2+ GB1024 MB
The default size of the heap is 512MB. Note that for systems with smaller amounts of physical memory, increasing the size of the heap may cause performance problems.

Resolving The Problem

To change the JVM's heap size, complete the following steps:
1. Click Start.
2. Right-click on the WebSphere® Business Modeler shortcut in your Start menu and select Properties. The properties window for the shortcut appears.
3. Append the following to the command string in the Target field:

-vmargs -Xmx<number>M

Where <number> is the heap size in megabytes.


4. Click OK.

When you start WebSphere® Business Modeler, the JVM uses the heap size you specified.

[{"Product":{"code":"SSBJDG","label":"WebSphere Business Modeler Advanced"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Performance\/Scalability","Platform":[{"code":"PF033","label":"Windows"}],"Version":"6.1;6.0;5.1.1","Edition":"Advanced","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

More support for:
WebSphere Business Modeler Advanced

Software version:
6.1, 6.0, 5.1.1

Operating system(s):
Windows

Document number:
81165

Modified date:
15 June 2018

UID

swg21193029

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