IBM Support

'Out Of Memory' Error When Opening IBM i2 iBase

Troubleshooting


Problem

Attempts to open IBM i2 iBase results in the error: Out Of Memory Error #7 occurred in: id5Error idSystemFunctions:LoadIcons idApplication:LoadApplication FMain:Initialise

Cause

This error message can be caused by corruption in the i2 registry keys, or if the user's My Documents folder has been re-directed to a network share which is offline/unavailable.

Resolving The Problem

If the user's My Documents folder is re-directed to a network share, ensure that the share is online and available before launching iBase. See the following Microsoft article for more information on configuring folder redirection: https://msdn.microsoft.com/en-us/library/cc786749%28v=ws.10%29.aspx

To fix corrupt i2 registry keys, run a repair installation of iBase:
1. In the Windows Control Panel, open Add/Remove Programs.
2. For Windows 7, right-click on i2 iBase and select 'Repair'. For Windows XP, click on the 'Change' button next to i2 iBase and select Repair from the install wizard.
3. Wait for the repair procedure to complete, then reboot the workstation.

In some cases, it has been found that there is corruption with the user's domain profile. If another user can log in and open iBase successfully on the same machine, delete the failing user's domain profile and create it from scratch.

[{"Product":{"code":"SSXW43","label":"i2 iBase"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.9;5.0","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21635777