IBM Support

Orphaned BIBusTKServerMain.exe processes hang

Question & Answer


Question

A large number of BIBusTKServerMain.exe processes running for a long time

Cause

BIBusTKServerMain.exe processes are spawned by your Cognos BI java.exe process when running CQM reports. There can be several different reasons for a large number of these process. You can set the number of processes to be spawned at a time in your Cognos Tuning settings. Depending on how many processes were running at the time of crash, it would be a good idea to review your Tuning settings and make sure it is
not set too high.

Answer

Assuming that the Tuning settings are correct and the BIBus processes
are just getting orphaned and hanging, here are some possible reasons
for that:

1) A user ran a huge report that might not be well designed and the BIBus process ran out of memory
2) The dispatcher is for some reason unable to communicate with the BIBus process and thus the process doesn’t kill itself after the timeout period.

If you run into a similar issue again you should follow the steps below

1) Right click on the orphaned BIBus process and create a dump file.
2) Take screenshot of the processes in Task Manger
3) Take screenshot of the server performance. E.g Memory and CPU usage.
4) Collect windows Event Viewer logs
5) Zip up the logs folder
6) Send all this information to IBM

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Cognos Administration","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1;10.1.1;10.2;10.2.1;10.2.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21987176