Troubleshooting
Problem
This technote describes an issue that might occur when an IBM® Rational® RequisitePro® client is using Oracle8i client software and is not able to connect to the Oracle Database.
Cause
The full error message is as follows:
Error: "SQLSTATE: NA00
Native error code: 0
Driver Message: [Microsoft][ODBC Driver for Oracle][Oracle]
Do you need any suggestions to avoid the error?"
The OCI components for the Oracle8i client have not been properly registered . For details see Microsoft knowledge base article 264012
Resolving The Problem
Manually add or modify the Oracle OCI registry entries to reflect the correct values. Follow the steps below to perform this task.
NOTE: This solution contains information about modifying the system registry. Before making any modifications to the Microsoft® Registry Editor, it is strongly recommended that you make a backup of the existing registry. For more information describing how to back up the registry, refer to the Microsoft Knowledge Base article 256986.
For Windows NT:
- Run regedt32.
- Under [HKEY_LOCAL_MACHINE\Software\Microsoft\Transaction Server\Local Computer\My Computer] add the following keys and values.
If any of the keys do not exist, add them:
OracleXaLib = oraclient8.dll
OracleSqlLib = orasql8.dll
OracleOciLib = oci.dll
For Windows 2000 or XP:
- Run regedt32.
- Under [HKEY_LOCAL_MACHINE\Software\Microsoft\MSDTC\MTxOCI] add the following keys and values:
OracleXaLib = oraclient8.dll
OracleSqlLib = orasql8.dll
OracleOciLib = oci.dll
For Windows 9.x:
- Run regedit.
- Under [HKEY_LOCAL_MACHINE\Software\Microsoft\Transaction Server\Local Computer\My Computer] add the following keys and values.
If any of the keys do not exist, add them:
OracleXaLib = oraclient8.dll
OracleSqlLib = orasql8.dll
OracleOciLib = oci.dll
Reboot the workstation after you have added or modified the keys.
Related Information
Historical Number
112318524
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Document Information
Modified date:
16 June 2018
UID
swg21135340