IBM Support

Oracle "CASE WHEN EXISTS" Statement Not Recorded in InfoSphere Guardium Report

Troubleshooting


Problem

When monitoring Oracle database traffic, the SQL statement which contains keywords "CASE WHEN EXISTS" is not recorded in FULL SQL report.

Symptom

For example, if following SQL statement is issued on Oracle DB side:

SELECT * FROM TEST1 WHERE C1=1 AND (CASE WHEN EXISTS (SELECT 1 FROM TEST2 WHERE C2=1 ) THEN '1' ELSE '0' END)='1';

In Full SQL report, this SQL statement doesn't appear.

Cause

This is a bug fixed in V9 next GPU.

Resolving The Problem

This issue was identified after GPU 9.0p200 was released, and will be fixed in the next GPU. If you hit this issue and need an ad-hoc patch, please contact IBM Support.

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Guardium Database Activity Monitor","Platform":[{"code":"PF016","label":"Linux"}],"Version":"9.1;9.0","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}},{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21681683