IBM Support

ORA-27191, return code 3505 Data Protection for Oracle back failure

Troubleshooting


Problem

Data Protection for Oracle backups in a RAC environemnt can fail with ORA-27191, RC 3505

Symptom

Output from the RMAN log:


RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03009: failure of crosscheck command on ORA_SBT_TAPE_1 channel at <date / time>
ORA-27191: sbtinfo2 returned error
Additional information: 3505

Cause

Data Protection for Oracle versions are different on one or more of the nodes in the cluster. In a typical RAC environment, Oracle will determine which node is the best candidate to perform the requested commands, even if it was initiated from another node.

Environment

Oracle databases in a RAC (Real Application Cluster) environment.

Resolving The Problem

Ensure that all of the nodes in the cluster are running the same Data Protection for Oracle and Tivoli Storage Manager / IBM Spectrum Protect Client levels.

This behavior may also be encountered in an atypical environment, where the backups in a RAC environment are being limited to one of the nodes in the cluster by setting the ORACLE_SID to the local instance, instead of the Cluster instance. A full backup should be performed before any log archives are attempted for backup. If performing backups from other nodes in the RAC, ensure that those are complete before initiating a backup on the problem node.

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Product Synonym

TSM

Document Information

Modified date:
17 June 2018

UID

swg21980254