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A "ORA-00942: table or view does not exist" database exception occurs with WebSphere Process Server (WPS)

Troubleshooting


Problem

You cannot access failed event data after you open the Failed Event Manager console. WebSphere Process Server cannot access the Failed Event table successfully, so a database " ORA-00942: table or view does not exist" exception occurred.

Symptom

The following messages exist in the log file:


Caused by: org.omg.CORBA.TRANSACTION_ROLLEDBACK:                        
javax.transaction.TransactionRolledbackException:  ; nested exception  
is:                                                                    
 java.sql.SQLException: ORA-00942: table or view does not exist        
DSRA0010E: SQL State = 42000, Error Code = 942  vmcid: 0x0  minor code:
0  completed: No                                                        
 at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native      
Method)                                                                
 at                                                                    
sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorA
ccessorImpl.java:67)                                                    
 at                                                                    
sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingCons
tructorAccessorImpl.java:45)                                            
 at java.lang.reflect.Constructor.newInstance(Constructor.java:522)    
 at com.ibm.rmi.util.ProxyUtil.copyObject(ProxyUtil.java:341)          
 at                                                                    
com.ibm.CORBA.iiop.UtilDelegateImpl.copyObject(UtilDelegateImpl.java:857
)                                                                      
 at javax.rmi.CORBA.Util.copyObject(Util.java:333)                      
 at                                                                    
com.ibm.wbiserver.manualrecovery.ejb._FailedEventManagerEJB_Stub.getFail
edEventCount(_FailedEventManagerEJB_Stub.java:284)                      

Cause

One of the following situations exists:

  • Situation 1: A user in the WebSphere Process Server database account does not have access privileges to the Failed Event table.

  • Situation 2: A database table is corrupt due to migration or an upgrade.

  • Situation 3: A synonym is missing in the Oracle database.

Resolving The Problem

Complete one of the following approaches to resolve the issue:

  • Situation 1: Use an account with the appropriate database privileges.

  • Situation 2: Recreate the table.

  • Situation 3: Create the synonym manually.

[{"Product":{"code":"SSQH9M","label":"WebSphere Process Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Failed Management Console","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"7.0.0.4;7.0.0.3;7.0.0.2;7.0.0.1;7.0;6.2.0.3;6.2.0.2;6.2.0.1;6.2;6.1.2.3;6.1.2.2;6.1.2.1;6.1.2;6.1.0.4;6.1.0.3;6.1.0.2;6.1.0.1;6.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
15 June 2018

UID

swg21572586