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Operations in CCRC such as checkout or checkin exhibit poor performance

Troubleshooting


Problem

This technote identifies an issue when using IBM Rational ClearCase Remote Client (CCRC) where operations such as checkout, uncheckout or checkin are exhibiting poor performance.

Symptom

Common operations such as checkout, uncheckout or checkin take too long in deeply nested directories and directories with symbolic links.

Cause



This issue has been identified as a product defect under APAR PM03326.

Environment

Windows operating system

Diagnosing The Problem


Steps to reproduce:

  1. Startup CCRC and/or Rational Developer for System z (RDz) CCRC
  2. Connect and set into the View (in this case a UCM view. )
  3. Make sure all the expansion buttons in the left pane of ClearCase Explorer are minimized.
  4. Checkout and uncheckout will behave normal .

    Now :
  5. Expand one of the VOB directories in the left pane of the ClearCase Explorer.
  6. Try a checkout or uncheckout on any file into another directory other than the expanded one.
  7. Closing the expansion does not fix the problem. The same behavior will be persistent in the same view where the expansion happened.
  8. To start fresh : restart the Eclipse client CCRC or RDz CCRC, and make sure that the directories in the left pane of CC Explorer are not expanded except for the one you are working in .

Do the checkout and all is fine again.

Resolving The Problem


The defect has been resolved in ClearCase 7.1.1.1.

[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"ClearCase Remote Client","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.1.0.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
19 February 2019

UID

swg21421265