Troubleshooting
Problem
This technote identifies an issue when using IBM Rational ClearCase Remote Client (CCRC) where operations such as checkout, uncheckout or checkin are exhibiting poor performance.
Symptom
Common operations such as checkout, uncheckout or checkin take too long in deeply nested directories and directories with symbolic links.
Cause
This issue has been identified as a product defect under APAR PM03326.
Environment
Windows operating system
Diagnosing The Problem
Steps to reproduce:
- Startup CCRC and/or Rational Developer for System z (RDz) CCRC
- Connect and set into the View (in this case a UCM view. )
- Make sure all the expansion buttons in the left pane of ClearCase Explorer are minimized.
- Checkout and uncheckout will behave normal .
Now :
- Expand one of the VOB directories in the left pane of the ClearCase Explorer.
- Try a checkout or uncheckout on any file into another directory other than the expanded one.
- Closing the expansion does not fix the problem. The same behavior will be persistent in the same view where the expansion happened.
- To start fresh : restart the Eclipse client CCRC or RDz CCRC, and make sure that the directories in the left pane of CC Explorer are not expanded except for the one you are working in .
Do the checkout and all is fine again.
Resolving The Problem
The defect has been resolved in ClearCase 7.1.1.1.
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Document Information
Modified date:
19 February 2019
UID
swg21421265