Troubleshooting
Problem
onbar returns -329 database not found or no system permission
Symptom
SQL -329 Database not found or no system permission errors returned in the Bar_Act.log file.
Cause
The sysutils database is missing
Diagnosing The Problem
Errors similar to the following will be displayed in the Bar_Act.log file:
2011-05-31 11:33:55 630950 487566 /opt/informix/bin/onbar_d -b
2011-05-31 11:33:56 630950 487566 Archive started on rootdbs, sendq, dbs1, dbs2, logdbs (Requested Level 0).
2011-05-31 11:33:56 630950 487566 SQL -329 Database not found or no system permission.
2011-05-31 11:33:56 630950 487566 ISAM -111 ISAM error: no record found.
2011-05-31 11:33:56 630950 487566 SQL -329 Database not found or no system permission.
2011-05-31 11:33:56 630950 487566 ISAM -111 ISAM error: no record found.
2011-05-31 11:33:56 630950 487566 Begin level 0 backup rootdbs.
2011-05-31 11:33:57 630950 487566 Successfully connected to Storage Manager.
2011-05-31 11:34:25 630950 487566 SQL -329 Database not found or no system permission.
2011-05-31 11:34:25 630950 487566 ISAM -111 ISAM error: no record found.
Resolving The Problem
Create the sysutils database by running the bldutil utility in $INFORMIXDIR/etc on UNIX or %INFORMIXDIR%\etc on Windows.
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Document Information
Modified date:
16 June 2018
UID
swg21501564