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ODBC Error connecting to an Oracle 8i database with RequisitePro

Troubleshooting


Problem

This technote describes how to resolve problems connecting an Oracle® 8i database in IBM Rational® RequisitePro®. The following error message is received, when trying to connect to a IBM® Rational® RequisitePro® project that is held in an Oracle 8i database: [][Microsoft][ODBC driver for Oracle][Oracle] -Unable to connect to the database. -Ensure that the configuration and account information are valid.[]

Cause

These errors are generic and may have different causes.

Resolving The Problem

IMPORTANT: Notice that there is no additional information after the [ODBC driver for Oracle][Oracle] line of text in the error.

The error above is common, but normally has additional information after the above text. This is not a solution for these type of error messages where additional text occurs after the above error message.

For example:
[Microsoft][ODBC driver for Oracle][Oracle]ORA-12535: TNS: operation timed out.

Further tests need to be made, as the error does not give enough information to pinpoint where the problem is. To get more information about the problem, the Microsoft ODBC for Oracle driver must be tested outside of RequisitePro.

There are two methods to test this driver:

  1. Technote 1119800 describes how to test this driver using the Oracle ODBC test.
  2. Technote 1134396 describes how to test this driver using a "UDL" test. The "UDL" test can normally only be performed if MS Access is installed on the PC.

If an error occurs with either of these tests, it indicates a problem with the Microsoft ODBC for Oracle driver itself, which is not a component supported by Rational.

However, Technote 1135340 describes a particular error that can occur when testing the driver using one of the methods above. It also references the suggested resolution from Microsoft® if this specific error is encountered.





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Historical Number

123809009

Document Information

Modified date:
29 September 2018

UID

swg21135480