Troubleshooting
Problem
This technote identifies the cause and resolution to the error, The ODBC Driver Microsoft Access (*.mdb) is not properly setup on your computer, which is a defect that appears in IBM® Rational® RequisitePro® when a user attempts to create a project using an IBM DB2® database.
Cause
The full error message is as follows:
The ODBC database driver Microsoft Access Driver (*.mdb) is not properly setup on your computer. RequisitePro requires the driver to communicate with this project database.
This error is a known issue in RequisitePro and is caused by having too many ODBC drivers installed on a machine.
The installation and setup of DB2 or Oracle creates a large number of ODBC entries in the odbcinst.ini folder in the registry. When using RequisitePro version 2003.06.13 and later this error appears, because RequisitePro only allocates 1024 characters for the list of potential ODBC Connections.
This error is more frequent with 2003.06.13 (SR3) because RequisitePro has added new drivers to support IBM DB2.
This is error is also caused by IBM Rational ClearQuest® which also adds additional drivers for supported databases.
Resolving The Problem
This issue has been identified as a product defect and has been logged under RATLC00731309, which has been resolved in RequisitePro version 2003.06.15
This problem occurs when a large number of ODBC drivers are installed on your system. If you have IBM Rational ClearQuest® and RequisitePro installed, you likely will encounter this error as ClearQuest installs new ODBC drivers in 2003.06.13.
The workaround is to remove unused Microsoft® drivers from the registry until you successfully open the RequisitePro project stored in DB2.
NOTE: This solution contains information about modifying the system registry. Before making any modifications to the Microsoft® Registry Editor, it is strongly recommended that you make a backup of the existing registry. For more information describing how to back up the registry, refer to the Microsoft Knowledge Base article 256986 http://support.microsoft.com/kb/256986.
- From Start > Run, enter regedit.
- Navigate to the following registry key: HKey_Local_Machine\Software\ODBC\Odbcinst.ini\ODBC Drivers\
- Delete keys for ODBC drivers you will not use.
As an example, you might delete the following (Suggestion for non-Spanish countries)

- Once you have cleared out all of the ODBC drivers you currently do not use you should be able to open the RequisitePro project.
Was this topic helpful?
Document Information
Modified date:
16 June 2018
UID
swg21192790