IBM Support

Support Policy for Microsoft Windows Vista

Question & Answer


Question

What is the support policy for IBM Rational ClearCase running on Microsoft Windows Vista?

Answer

The information below provides details about the support requirements for running Rational ClearCase or ClearCase LT on Windows Vista.

Rational ClearCase clients are supported on Windows Vista.

IMPORTANT: Before reviewing the list below, refer to technote 1257474 for a list of known restrictions and limitations with this release of ClearCase support on Windows Vista. ClearCase 8.0 support data for the table below has been incorporated into System Requirements for ClearCase 8.0.


Version
ServerClient
Operating System
Platform
Comments
ClearCase
7.0.0.1, 7.0.1, and 7.1

No

Yes





Windows Vista Business


Enterprise Edition


Windows Vista Ultimate

32-bit

64-bit *

Requires patch 7.0.0.1 ifix 01

CCLT on 64-bit Windows Vista will not be supported
CCLT
7.0.0.1 and 7.0.1

No

Yes

32-bit
Only




CCRC Eclipse IDE (plug-in) 7.0.1.CU02 or later





--





Yes





--
Requires Eclipse and JRE versions that support Vista.

Eclipse 3.2.2 or greater and IBM JRE 1.4.2 SR7 or greater recommended.

Review CCRC System Requirements
Global Monitor***
7.0.0.1, 7.0.1

No

No

--

--
Refer to technote 1415015 for supported platform and version information for ClearCase 7.1 and later.
CCRC RCP Client **
7.0.1.D06 or later


--

Yes

--

--

* IMPORTANT: FlexLM licensing is not supported on Windows Vista 64-bit editions. Atria Licensing is required on 64-bit editions. Review technote 1128958 for more details about Atria Licensing if required.

** ClearCase Remote Client (CCRC) Rich Client Platform (RCP) is also known as the stand-alone CCRC client.

*** Installation of Global Monitoring Server components require a server class machine (for example, Windows Server, Solaris, or others). However, Global Monitoring Reports can be viewed from Windows 7 and Windows Vista using any Web Browser.

Note: For the purposes of this technote, ClearCase Server is defined as a host storing VOBs. You can store views on a Client. With respect to MultiSite, this installation is designed for servers only. Clients do not need MultiSite installed to access replicated VOBs.

Feature Enhancements
  • Change request, (RFE) RATLC01358603, has been opened to allow MVFS support for Windows Vista SP1. Support for Windows Vista SP1 was added in 7.0.0.3 and 7.0.1.2 and later.

  • Change request, (RFE) RATLC01027748, was open for Rational ClearCase to support UAC. Support for UAC and BitLocker was added with ClearCase 7.1.2 by RFE RATLC01307346.

    You can view the status or post comments for RFE RATLC01307346 on the Rational Software RFE Community Web site.


Rational RFE Community homepage

Refer to the Rational RFE Community homepage for details and status of Requests for Enhancements for Rational products.

Refer to the following technotes for further information about ClearCase system requirements:







Before upgrading an existing Rational ClearCase 7.0.0.x or 7.0.1.x client to Microsoft Windows Vista

If you are upgrading to Microsoft Windows Vista on a computer that is currently running Rational ClearCase, you must follow this procedure:

  1. Move all hosted view storage to another machine (for the purposes of preparing for the OS upgrade as well as backing up the views).

  2. Uninstall Rational ClearCase.

  3. Upgrade your computer's operating system to Microsoft Windows Vista.

  4. Create a Rational ClearCase release area from version 7.0.0.1 or version 7.0.1. For details on creating a Rational ClearCase release area and installing Rational ClearCase, review the Rational ClearCase, ClearCase MultiSite, and ClearCase LT Installation and Upgrade Guide (pdf copy GI11-6365-00).

    Note: If you are upgrading an existing Rational ClearCase 7.0.x release area, the only allowable upgrade path to Rational ClearCase Version 7.0.0.1 IFix02 is from either of these two releases: Rational ClearCase Version 7.0.0.1 or Rational ClearCase Version 7.0.0.1 ifix01


    For version 7.0.0.1, apply Rational ClearCase version Rational ClearCase Version 7.0.0.1 or later to that release area.

    Note: Rational ClearCase Version 7.0.0.1 IFix02 is specifically designed to support Microsoft Windows Vista. Do not install this version of Rational ClearCase on any other versions of Microsoft Windows. Use Rational ClearCase Version 7.0.0.1 IFix01 instead.



Installing Rational ClearCase on Microsoft Windows Vista
  • Installing ClearCase 7.1:



  • Installing ClearCase versions prior to 7.1:
    Install Rational ClearCase from the newly created release area.

    Note: In Microsoft Windows Vista, you cannot install Rational ClearCase directly from a CD or using a downloaded installation or upgrade patch. You can only install from the updated release area.

[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Installation","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.0.0.1;7.0.1;7.1;7.1.2;8.0;8.0.1","Edition":"","Line of Business":{"code":"LOB36","label":"IBM Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21257224