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"Server is not reachable or still initializing, please refresh the page in a few seconds" error launching Controller Web caused by incorrect JAVA_HOME setting (inside 'server.env')

Troubleshooting


Problem

User launches Controller Web. An error appears.

Symptom

image-20190425134536-1
Server is not reachable or still initializing, please refresh the page in a few seconds

Cause

There are several known causes for the 'Server is not reachable or still initializing, please refresh the page in a few seconds' error.
  • TIP: See separate IBM Technote #0791129 for more examples.
This Technote specifically relates to the scenario where the cause is that the configuration file 'server.env' contains the wrong setting.
  • Specifically, the value for 'JAVA_HOME' was incorrect.
Example:
In one case, the setting was configured as:
    JAVA_HOME=C:/Program Files/IBM/cognos/ccr_64/fcmweb/jre/jre
image-20190618090159-1
This is incorrect for the (default) settings of Controller 10.4.1 (which expects the value to be: C:/Program Files/IBM/cognos/ccr_64/fcmweb/jre).

Diagnosing The Problem

1. Open the 'backend' logs folder.
  • TIP: By default, this is here: C:\Program Files\IBM\cognos\ccr_64\fcmweb\wlp\usr\servers\fcm.web\logs
2. Open the most recent 'fcmweb-stderr-xxxxxx' log file (inside Notepad).
Example:
2019-06-18 07:19:48 Commons Daemon procrun stderr initialized
The system cannot find the path specified.

2019-06-18 07:34:39 Commons Daemon procrun stderr initialized
The system cannot find the path specified.

Resolving The Problem

Reconfigure the file 'server.env'.
Steps:
1. Logon to the Controller application server
2. Browse to the 'etc' folder
  • TIP: By default, this is here: C:\Program Files\IBM\cognos\ccr_64\fcmweb\wlp\etc
3. As a precaution, create a backup copy of the file:    server.env
4. Edit the following file in NOTEPAD:       server.env
5. Modify the settings to be correct.
Example: For most customers this should be:
    JAVA_HOME=C:/Program Files/IBM/cognos/ccr_64/fcmweb/jre
6. Save changes
7. Obtain downtime (no users using Controller) and restart the application server.

Document Location

Worldwide

[{"Business Unit":{"code":"BU002","label":"Business Analytics"},"Product":{"code":"SS9S6B","label":"Cognos Controller"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.4.1","Edition":""}]

Document Information

Modified date:
18 June 2019

UID

ibm10888049