Troubleshooting
Problem
Attempts to use IBM Rational products on non-English Microsoft Windows operating system where double byte characters are used in system paths results in the error "License key check failed: .... does not have a valid license key to run".
Symptom
Using Rational Software Architect as an example, the following or similar Licensing Information dialog might appear:
License key check failed: IBM Rational Compare and Merge Server does not have a valid license key to run.
The installation has finished successfully but in the log file, the "tryAndBuy license" error is listed:
94 | ERROR | 49:21.43 | Error while trying installing the tryAndBuy license |
Note: The error also can be seen from the IBM Installation Manager logs by going to File > View Log or File > Installation History as shown below:
and
or by going to the specific directory located in
C:\Documents and Settings\All Users\Application Data\IBM\Installation Manager\logs
Attempts to install the permanent license using Installation Manager > Manage Licenses as described in the Getting Started guide, results in a successful finish but the log file shows the following errors:
9 | ERROR | 00:45.96 | LUM check failed for productID 10: License not found in the database. |
10 | ERROR | 00:46.00 | LUM check failed for productID 10: License not found in the database. |
11 | ERROR | 00:47.84 | LUM check failed for productID 10: License not found in the database. |
12 | ERROR | 00:48.17 | LUM check failed for productID 10: License not found in the database. |
Note: The "productID 10" in the example above is for Rational Software Architect. The productID could differ when the log is for another desktop product (Rational Application Developer for WebSphere Software, Rational Software Modeler, Rational Manual Tester, Rational Functional Tester, Rational Systems Developer).
If the error is not present in the log or your machine is not non-English Microsoft® Windows® operating system where double byte characters are used, then the problem you are experiencing is likely with a different root cause.
Cause
The IBM Installation Manager v1.0. has the limitation that it cannot handle double byte or unicode characters in the file paths where the Installation Manager stores its application data and where the license key (nodelock) file is also located.
By default, these files are stored in the directory :
C:\Documents and Settings\All Users\Application Data\IBM\Installation Manager which might have a different name or contain double byte characters that will prevent the license path to be retrieved correctly when you start the tool.
This can be checked by inspecting the files stored in:
- <IM_INSTALL_DIR>\eclipse\configuration\config.ini
(for example: C:\Program Files\IBM\Installation Manager\eclipse\configuration\config.ini)
where the cic.appDataLocation and osgi.instance.area properties need to be set with a value that does not contain special characters or unicode.
For example, on a Czech operating system:
C:\\Documents and Settings\\All Users\\Data Aplikací\\IBM\\Installation Manager
- <SDP70_INSTALL_DIR>\configuration\config.ini
(eg C:\Program Files\IBM\SDP70\configuration\config.ini)
where the cic.appDataLocation property needs to be set with a value that does not contain any special characters or unicode.
For example, on a Czech operating system:
C\:\\Documents and Settings\\All Users\\Data aplikac\u00ED\\ibm\\Installation Manager
Resolving The Problem
WORKAROUND:
To work around this problem, when installing the IBM Installation Manager, provide it with a path that contains no special characters) by running the following command:
install_win32.exe -appDataLocation C:\IBM\imappdata
This will install IBM Installation Manager. with the default appData location set to C:\IBM\imappdata rather than the one set at the operating system level.
You can also set a specific property called APPDATALOCATION in the install_win32.ini file in the disk1 before the initial installation of the Installation Manager.
The property should be added like this:
[COMMON]
APPDATALOCATION=C:\IBM\imappdata
Note: The command should be used ONLY when IBM Installation Manager is not installed on the system.
Related Information
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Document Information
Modified date:
25 October 2021
UID
swg21252014