IBM Support

SAz/OS controlled APL goes to STUCK status

Troubleshooting


Problem

SAz/OS not changing the status of APLs to DOWN or AUTODOWN after the APLs stopped, resulting in the APLs going to STUCK Status.
 

Cause

The reason the APLs went to STUCK is because SAz/OS did not track the IEF404I (Job ended) message, so SAz/OS did not set the status to DOWN, resulting in SAz/OS going through all the defined SHUTDOWN commands in the policy for the APL, that all failed because the APL was already down.
The reason SAz/OS did not track the IEF404I message is because the client had defined the APLs as 'Job Type' NONMVS which means the application cannot be monitored using the MVS DISPLAY ACTIVE command.

NONMVS applications must have startup command specified to prevent errors occurring during SAz/OS startup.  SAz/OS ignores the following
messages for status changes for NONMVS APLs.  This is however necessary if the jobname is not unique of the application is not a process:
- IEF403I - Job started
- IEF404I - Job ended
- IEF450I - Job abended

Resolving The Problem

This issue was resolved by changing the 'Job Type' from NONMVS to MVS.
See the ISPF online help, and 'Job Type' in the 'Creating a New Application' topic for move information: https://ibm.biz/BdzxEL

Related Information

Document Location

Worldwide

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Document Information

Modified date:
11 April 2019

UID

ibm10880773