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Release Note: Case solution snapshots and their active process instances can't be migrated

Release Notes


Abstract

Case solution snapshots and their process instances that might be active can't be migrated. Therefore, you try to migrate such instances, the instance migration fails. Instances that are currently running must continue to completion using the previously installed snapshot.

Content

Symptom
You see an exception when IBM Business Automation Workflow detects that a snapshot you're trying to migrate from belongs to a case solution.
CWLLG1279E: There was a failure to migrate from snapshot 2064.a2cf2451-603d-4d9d-9684-36242ebcd2b2 to snapshot 2064.eb7e02df-c082-4c70-9830-70caf28c8838.
com.lombardisoftware.core.TeamWorksException: Message: integration.ecm.failure.CannotMigrateSolutionSnapshot Arguments: V2.2 PRD Snapshot.a2cf2451-603d-4d9d-9684-36242ebcd2b2
Cause
An API is not currently available for Business Automation Workflow to call to invoke synchronization between ECM and Business Automation Workflow once instance migration is completed.
Resolving The Problem
Ensure running instances that come from case snapshots are completed in the context of their original snapshot.

[{"Type":"MASTER","Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS8JB4","label":"IBM Business Automation Workflow"},"ARM Category":[{"code":"a8m0z000000cwEvAAI","label":"Case Management"}],"ARM Case Number":"","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"21.0.2;21.0.3;19.0.0.1;19.0.0.2;19.0.0.3;20.0.0.1;20.0.0.2"}]

Document Information

Modified date:
17 December 2021

UID

ibm10878504