IBM Support

Release Note: A user name longer than 35 characters causes the Case configuration tool task "Configure Case Integration with IBM Business Automation Workflow" to fail

Release Notes


Abstract

If a user name that is longer than 35 characters is used in the Case configuration tool task “Configure Case Integration with IBM Business Automation Workflow”, the task fails.

Content

Symptom
When the Case configuration tool task “Configure Case integration with IBM Business Automation Workflow” fails due to a user name that exceeds 35 characters, the following error message appears in the Case configuration tool log:
Define Target Environment * Configure Case Integration with IBM Business Automation Workflow
An error occurred while running Configure Case Integration with IBM Business Automation Workflow The task failed because of the following error: The value given for a property or list element lies outside the permitted range or value set, or exceeds the maximum length allowed. The length of the value (160) specified for property CmAcmUserName1 exceeds the maximum permitted length (128).
Cause
Because of an issue related to encryption in the Case configuration tool, there is a limitation on the length of the user name that can be used with the "Configure Case Integration with IBM Business Automation Workflow" task.
Diagnosing The Problem
In the Case configuration tool logs, look for the following error message:
Step 5: Define Target Environment * Configure Case Integration with IBM Business Automation Workflow
An error occurred while running Configure Case Integration with IBM Business Automation Workflow The task failed because of the following error: The value given for a property or list element lies outside the permitted range or value set, or exceeds the maximum length allowed.
Resolving The Problem
In IBM Business Automation Workflow 19.0.0.1, it is recommended that you use a user name that is fewer than 35 characters long while running the Case configuration tool task "Configure Case Integration with IBM Business Automation Workflow".
Alternatively, you can configure Business Automation Workflow to support long user name while running the "Configure case integration with Business Automation Workflow" task:
  1. In the administrative console for Content Engine, go to the Target Object Store (tos).
  2. Go to Data Design > Classes > Custom Objects and select the OneBPM Integration Data custom object.
  3. Go to Property Definitions and select the User Name 1 property definition.
  4. On the More tab, change the maximum string length from 128 to 1056.
  5. Repeat this procedure for the User Name 2 property definition.
  6. Click Save.
This problem will be fixed in a future release.

[{"Type":"MASTER","Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS8JB4","label":"IBM Business Automation Workflow"},"ARM Category":[{"code":"a8m0z000000cwMpAAI","label":"Case Management-\u003ECase Install\/Upgrade\/Setup-\u003ECase Configuration Tool"}],"ARM Case Number":"","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"21.0.2;21.0.3;19.0.0.1;19.0.0.2;19.0.0.3;20.0.0.1;20.0.0.2"}]

Document Information

Modified date:
17 December 2021

UID

ibm10875886