Troubleshooting
Problem
The Server activity log reports the following message after a LAN Free client fails: ANR8779E Unable to open drive
Cause
Symbolic links are used for the DEVICE parameter in the DEFINE PATH command. Normally setting RESETDRIVE=YES in the library definition will have the effect of issuing a LUN reset by the Server to the drives held by a failed LAN Free client. The LUN reset command fails when the drive path parameter is a symbolic link to the actual drive path. The Tivoli Storage Manager server will report the error for each drive allocated to the LAN Free client, and will repeat the error once every minute when the Server attempts to reclaim the drive. This error will be reported in the activity log indefinitely until actions are taken to free the drive.
Resolving The Problem
Redefine the drive paths on the Tivoli Storage Manager server to use the correct drive path file names. Symbolic links for drive paths are not a supported configuration for device definitions.
Make sure the library definition has the RESETDRIVE parameter set to YES when using LAN Free clients; this will allow the server to reclaim the drives from Storage Agent clients that have failed.
When RESETDRIVE is working the following line will appear in a TSM Server PVR trace: PvrResetDev called for /dev/rmtX.
Note: If the Storage Agent IBM device driver has DPF (Dynamic Path Failover) feature enabled, the library manager will not be able to use LUN RESET to clear the drive reservation. The reason is LUN RESET can not clear the reservation made by Persistent Reserve used in DPF.
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Document Information
Modified date:
17 June 2018
UID
swg21249613