IBM Support

GSKit levels distributed by IBM Spectrum Protect

Question & Answer


Question

What IBM Global Security Kit (GSKit) versions are included in the IBM Spectrum Protect products? 

Answer


Overview

Secure Sockets Layer (SSL) or the Transport Layer Security (TLS) protocol provide transport layer security for a secure connection between servers, clients, and storage agents. The IBM® Global Security Kit (GSKit) provides libraries and utilities for SSL or TLS communication. Those libraries are used by IBM Spectrum Protect product components. When several IBM Spectrum Protect products or other IBM products are used, it is recommended to use the same GSKit versions or the latest version to ensure interoperability.

Note: To ensure that a single source of GSKit libraries is used, the symbolic link approach can be used, see in steps IBM Knowledge Center: Creating a symbolic link to access the latest GSKit library


GSKit versions in IBM Spectrum Protect

The following tables list the versions where a GSKit version introduced:


Release 7.1

Version of Backup-Archive client & API Version of GSKit
V7.1.8 8.0.50.78
V7.1.8.2 8.0.50.86
V7.1.8.5 8.0.55.2
V7.1.8.6 8.0.55.4
V7.1.8.7 8.0.55.9
V7.1.8.9 8.0.55.14
V7.1.8.10 - until latest delivery in this release 8.0.55.17 (all OSs except macOS),
8.0.55.14 (macOS)

Note:


Release 8.1

Version of Backup-Archive client & API Version of GSKit
V8.1.2 - V8.1.4 8.0.50.78
V8.1.4.1 - V8.1.6 8.0.50.86
V8.1.6.1- V8.1.7.1 8.0.55.2
V8.1.8 8.0.55.4
V8.1.9 8.0.55.9
V8.1.10 8.0.55.14 (all OSs except macOS),
8.0.55.15 (macOS)
V8.1.11 8.0.55.17
V8.1.12 - until latest delivery in this release 8.0.55.21

See the latest downloads for this release in IBM Spectrum Protect Downloads - Latest Fix Packs and interim fixes
 

Version of Data Protection for VMware Version of GSKit
V8.1.2 - V8.1.4 8.0.50.78
V8.1.4.1 - V8.1.6 8.0.50.86
V8.1.6.1- V8.1.7 8.0.55.2
V8.1.8 8.0.55.4
V8.1.9 8.0.55.9
V8.1.10 8.0.55.14
V8.1.11 8.0.55.17
V8.1.12- until latest delivery in this release 8.0.55.21

Version of Data Protection for Microsoft Hyper-V Version of GSKit
V8.1.4 8.0.50.78
V8.1.4.2 - V8.1.6 8.0.50.86
V8.1.6.1 - V8.1.7 8.0.55.2
V8.1.8 8.0.55.4
V8.1.9 8.0.55.9
V8.1.10 8.0.55.14
V8.1.11 8.0.55.17
V8.1.12 - until latest delivery in this release 8.0.55.21

See the latest downloads for this release in Featured Documents for IBM Spectrum Protect™ for Virtual Environments


GSKit versions in other products

For GSKit Versions that included with Db2, see GSKit Versions included with IBM Db2

For GSKit Versions that included with Domino, see Resolving GSKit incompatibility between Domino and IBM Spectrum Protect for Domino

[{"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Product":{"code":"SSEQVQ","label":"IBM Spectrum Protect"},"Component":"","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF017","label":"Mac OS"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"7.1, 8.1","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
20 April 2021

UID

ibm10870512