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Error: The textual definition of requirement **** has changed since your last update

Troubleshooting


Problem

This technote identifies that the error, "The textual definition of requirement **** has changed since your last update," might occur if you are saving a document in IBM® Rational® RequisitePro® when the text in the database does not match the requirement text in a document.

Cause

The full error message:


The textual definition of requirement **** has changed since your last update.
- The requirement will be refreshed from the database. Make your changes again.

The error usually occurs when the text of the requirement in the Microsoft Word document and the text in the database do not match. This could also be caused by using special characters that are not supported by the database.

Resolving The Problem

To resolve this issue, compare the text in the document to the description of the requirement in the database.

Update the text in the Rqrequirements table in the RequisitePro database to match the description in the document.

OR

Update the text in the document to match the description in the Rqrequirements table in the RequisitePro database.


[{"Product":{"code":"SSSHCT","label":"Rational RequisitePro"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Document Properties","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2003.06.00;2003.06.01;2003.06.10;2003.06.12;2003.06.13;2003.06.14;2003.06.15;7.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21247795