IBM Support

Detailed System Requirements for RequisitePro 7.0

Question & Answer


Question

This technote provides you with information about IBM Rational RequisitePro. Which operating systems, databases, Web browsers, Web servers and hosted development environments are supported by IBM® Rational® RequisitePro® version 7.0? For supported platforms in the 7.1 release, see the release notes in the Information Center: http://publib.boulder.ibm.com/infocenter/reqpro/v7r1m0/index.jsp?topic=…

Answer









GLOSSARY:
Hardware: The hardware on which RequisitePro is supported.

Operating System: The operating systems on which RequisitePro is supported.

Revision: Operating system patch or Service Release or selected version which RequisitePro is supported



RequisitePro v7.0 Windows native client
Hardware platform
Operating system
Comments
Intel® x86

Microsoft® Windows® 2000 Professional, Server, Advanced Server SP4
Microsoft Windows XP Professional, SP1, SP2, SP3SP3 Supported in 7.0.1.1 and higher.
Microsoft Windows 2003 Server, Enterprise Server, SP1, SP2
Microsoft Windows 2003 R2Supported in 7.0.1
Microsoft Windows Vista® Enterprise, Ultimate, and Business Edition, SP1 and SP2Supported in 7.0.1
SP2 Supported in 7.0.1.2, and 7.0.0.3
AMD64 & EM64TMicrosoft Windows 2003 Server x64Must be running in 32-bit mode on 64-bit processors
Microsoft Windows XP Professional x64Must be running in 32-bit mode on 64-bit processors
Note: LAN Support: Microsoft networks




RequisitePro v7.0 Hosted environments
Terminal Server
Product version/ Operating system
Comments
Windows Terminal Servers
    Microsoft Windows 2000 Advanced Server, SP4

    Microsoft Windows 2003 Enterprise Server, SP1, SP2

Citrix
MetaFrame
    Citrix MetaFrame XP, 3, 4, 5
5 on 7.0.1.10

Note: Review the following technotes for additional information on platform related support.






RequisitePro supported enterprise database servers
Database
Version
Service pack
Comments
IBM DB2®8.1

8.2

9.1
Support added in 7.0.1
IBM DB2 UDB Components for Rational Products8.1
Refer to technote 1238520 for important support information about UDB components.
8.2
9.1
Support added in 7.0.1
IBM DB2 Express 8.1

8.2

9.1
Support added in 7.0.1
IBM DB2 Express-C8.1
Refer to technote 1238520 for important support information about UDB components.
8.2
9.2
Support added in 7.0.1
Oracle9.2
Version 9.2.0.1.0 64 bit database supported with 7.0.0.1 iFix06 and 7.0.1 iFix01 only by both the RequisitePro and RequisitePro Web Clients.
10
Version 10.2.0.1.0 64 bit database supported with 7.0.0.1iFix06 and 7.0.1 iFix01 only by both the RequisitePro and RequisitePro Web Clients.
Microsoft SQL Server 2008
support added in version 7.0.1.8
20051, 2, 3SP1 support added in version 7.0.1, SP2 added in version 7.0.1.4, SP3 added in version 7.0.1.8
20002, 3, 4SP4 support added in version 7.0
74
Note: Microsoft Access versions 2000, 2002 and 2003 are supported as a non-production database for all Windows operating systems.
Note: LAN Support: Microsoft networks




RequisitePro supported Microsoft Office products
Platform
Version
Service pack
Comments
Microsoft Excel20001, 2
XP (2002)1, 2
20031, 2, 3
2007
Only supported in v7.0.1
Microsoft Project 2000No SP or 1
XP (2002)No SP
2003No SP
2007
Only supported in v7.0.1
Microsoft Word2000No SP
XP (2002)1, 2
20031, 2, 3
2007
Only supported in v7.0.1





RequisitePro supported Internet browsers
PlatformService packComments
Microsoft Internet Explorer 61
Microsoft Internet Explorer 7noneSupported in 7.0.0.1
Microsoft Internet Explorer 8
Supported in 7.0.0.9 and later and 7.0.1.7 and later
Firefox 1.0.7, 1.5 1, 2
Firefox 2.0noneSupported in 7.0.1
Mozilla 1.6, 1.71, 2






Change History
January 6, 2011Updated supported versions for MS SQL SP1-3
October 8, 2010v7.0.1.1 supported with Windows XP SP3
August 26,2010Added terminal server version 5 support
June 11, 2010Added Internet Explorer 8 support
Mar 24, 2010Added SP3 support in version 7.0.1.8 for Microsoft SQL Server
April 28, 2008Changed Hosted environments table so it says SP1 of Windows 2003 Enterprise Server
Feb 27, 2008Added Support for Office 2003 SP3
Nov 15, 2007Corrected FireFox version notation from 7.01 to 7.0.1
Oct 17, 2007Added in Internet browser information that is also listed on the RequisiteWeb System Requirements document.
Sept 5, 2007Added that the 2007 office products are only supported in version 7.0.1
Jun 25, 2007Updated with 7.0.1 support
Jan 24, 2007Added note about supported networks
Nov 28, 2006Updated the format of the System Requirements

[{"Product":{"code":"SSSHCT","label":"Rational RequisitePro"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Documentation","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"7.0;7.0.0.1;7.0.0.2;7.0.0.3;7.0.0.4;7.0.0.5;7.0.0.6;7.0.0.7;7.0.0.8;7.0.0.9;7.0.1;7.0.1.1;7.0.1.10;7.0.1.2;7.0.1.3;7.0.1.4;7.0.1.5;7.0.1.6;7.0.1.7;7.0.1.8","Edition":"","Line of Business":{"code":"LOB15","label":"Integration"}}]

Document Information

Modified date:
16 June 2018

UID

swg21239289