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DBA1177N when starting the DB2 Task Center

Question & Answer


Question

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Why am I receiving DBA1177N when starting the DB2 Task Center? This document provides troubleshooting information for when an attempt to start the DB2 Task Center gives the following error: DBA1177N a Database connection to the Tools Catalog Database " " cannot be made. SQLCODE=1013.

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Cause

Tasks created by the Task Center are stored in the tools catalog database. These tasks are managed by the DB2® Administrator Server's (DAS) Scheduler. The Scheduler acts as an agent to read the tools catalog database and runs the tasks at their respective times. The DB2 Administration Server configuration parameters tell the Scheduler the location of the tools catalog database, and whether or not the Scheduler should be enabled. When the tools catalog database is created, DB2 Universal Database™ (DB2 UDB) implicitly updates the DAS configuration parameters SCHED_ENABLE, TOOLSCAT_DB, TOOLSCAT_INST and TOOLSCAT_SCHEMA. This enables the Scheduler and defines the location of the tools catalog database without requiring you to restart the DAS.

Sample output from the command db2 get admin cfg is as follows:


...
Execute Expired Tasks                   (EXEC_EXP_TASK) = NO
Scheduler Mode                           (SCHED_ENABLE) = ON
SMTP Server                               (SMTP_SERVER) =
Tools Catalog Database                    (TOOLSCAT_DB) = TOOLSDB
Tools Catalog Database Instance         (TOOLSCAT_INST) = DB2
Tools Catalog Database Schema         (TOOLSCAT_SCHEMA) = TOOLSDB
Scheduler User ID                                       =
...

If the DAS is dropped then recreated, the DAS configuration parameters (SCHED_ENABLE, TOOLSCAT_DB, TOOLSCAT_INST and TOOLSCAT_SCHEMA) are reset to their default values and any attempt to start the Task Center will generate the error message:

DBA1177N a Database connection to the Tools Catalog Database " " cannot be made. SQLCODE=1013.

Sample output from the command db2 get admin cfg after dropping and recreating the DAS is as follows:

...


Execute Expired Tasks                   (EXEC_EXP_TASK) = NO
Scheduler Mode                           (SCHED_ENABLE) = OFF
SMTP Server                               (SMTP_SERVER) =
Tools Catalog Database                    (TOOLSCAT_DB) =
Tools Catalog Database Instance         (TOOLSCAT_INST) =
Tools Catalog Database Schema         (TOOLSCAT_SCHEMA) =
Scheduler User ID                                       =

Answer

To resolve the error message, manually update the DAS configuration file to locate the tools catalog database, enable the scheduler and restart the DAS instance. For example:

  1. db2 update admin cfg using SCHED_ENABLE on
  2. db2 update admin cfg using TOOLSCAT_DB <tools_db>
  3. db2 update admin cfg using TOOLSCAT_INST <instance>
  4. db2 update admin cfg using TOOLSCAT_SCHEMA <schema>
  5. db2admin stop
  6. db2admin start

Alternatively, you can drop and recreate the tools catalog database, which will dynamically update the DAS configuration parameters and enable the scheduler. Note that dropping the tools catalog database will cause the task information in the database to be destroyed. Exercise caution when choosing to drop this database. For example:
  1. db2 drop db toolsdb
  2. db2 create tools catalog toolsdb create new db toolsdb

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Document Information

Modified date:
16 June 2018

UID

swg21187847