Troubleshooting
Problem
Volumes on Windows host are configured on the FlashSystem-900 appeared as OFFLINE after the Windows server was rebooted.
Vdisks on the FlashSystem-900 itself are ONLINE and no error are seen on the IBM FlashSystem-900.
The IBM FlashSystem-900 was upgraded earlier from 1.5.1.2 to 1.5.2.1 and Windows server was rebooted at any later time (for example to apply patches).
Symptom
After Windows server reboot, the volumes didn't get mounted automatically due to a policy parameter on the windows server that couldn't use changed FlashSystem "SCSI Product Revision" ID field. The windows policy will result in inaccessible volumes.
Cause
Microsoft made a change to the default SAN Policy for Windows 2008 Enterprise and Datacenter Editions. The default policy is now Offline Shared. This is a departure from Windows 2003 and Windows 2008 SE.
IBM FlashSystem development tested multiple scenario with different code in the lab. They could confirm that the hardware ID changes after FlashSystem-900 concurrent code load (CCL), and the windows host volumes became OFFLINE after the host is rebooted for the first time after the FlashSystem CCL.
The change in the "SCSI Product Revision" field in the standard SCSI inquiry page is the trigger for Windows to prevent taking those volumes online after a FlashSystem-900 CCL, followed by Windows reboot.
To prevent this problem:
For hosts that fall within the above conditions, set the SAN Policy to 'Online All' prior to the host reboot. This will prevent the virtual disks from dropping offline after a reboot. Once the host is rebooted, the SAN Policy can be changed back to the default setting 'Offline Shared'.
For hosts that fall within the above conditions, set the SAN Policy to 'Online All' prior to the host reboot. This will prevent the virtual disks from dropping offline after a reboot. Once the host is rebooted, the SAN Policy can be changed back to the default setting 'Offline Shared'.
Environment
Windows volumes on FlashSystem 900-AE3 without SVC attachment.
Resolving The Problem
An older article, how to fix it: http://www.happysysadm.com/2010/11/disk-is-offline-because-of-policy-set.html
Recovery at a glance:
- query the current SAN policy from the command line with DISKPART
Once you have verified that the applied policy is Offline Shared, you have two options to set the disk to Online:
-
The first one is to log in to your system as an Administrator, click Computer Management > Storage > Disk Management, right-click the disk and choose Online.
- or - -
The second one is to make a SAN policy change, then select the offline disk, force a clear of its read-only flag and bring it online.
Document Location
Worldwide
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Document Information
Modified date:
17 February 2023
UID
ibm10795298