IBM Support

Powerplay report take a long time to run and display in Powerplay Studio

Troubleshooting


Problem

Opening or running a Powerplay report or view has poor performance, takes a long time to run and render in Powerplay Studio or PDF.

Symptom

The performance issue can be observed with a newly created report.  It may also occur with an existing report in a newly installed Powerplay Studio environment, whether it is a migration to a new server or an upgraded existing environment, where the same report performed well and ran in an expected amount of time in the previous environment or version of Powerplay Studio.

Cause

A large or complex Powerplay Studio report or view based on a large Powercube can result in continuous retrieval and caching of large amounts of data packets and impact the performance when running the report or view.

Environment

Powerplay Server 11.0.x integration with Cognos Analytics and Powerplay Server Plug-in for Cognos Analytics 11.1.x and 11.2.x releases.

Note that the same behavior may be observed in other Cognos Analytics tools such as Reporting, and Analysis Studio without Powerplay Server or powerplay Plug-in installed and configured in the environment.

Diagnosing The Problem

If the issue is encountered during a migration or upgrade, compare the Powerplay Server configuration and installation files in the new installation experiencing poor performance with the previous working Powerplay Server installation files for configuration differences that may contribute to the decreased performance.

Resolving The Problem

Enable the ppds_cfg.xml file and change the default UseUnpackedBitmaps setting. The default setting of 1 enabled the uncompressed mode of bitmap operations for Powerplay Server ppds processes.  The setting 0 enables compressed mode.

This configuration setting is applicable to Interoperating Powerplay Server 11.0.x versions and Powerplay Server Plug-in for Cognos Analytics 11.1.x and 11.2.x, 12.0.x and 12.1.x releases.

Steps:
1. On the server with the poorly performing Powerplay Server or Cognos Analytics server with the Poweplay Plug-in, make a copy of the <installation_directory>/configuration/ppds_cfg.xml.sample file and rename it to ppds_cfg.xml
2. Open the <installation_directory>/configuration/ppds_cfg.xml file in a text editor
3. Find the setting: 
<UseUnpackedBitmaps value="1"/>
4. Change the setting to :<UseUnpackedBitmaps value="0"/>
5. Save the file.
6. Restart
Powerplay services.
7. Test reports or views to evaluate the impact of this change on their performance.

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Product Synonym

BA

Document Information

Modified date:
06 May 2025

UID

ibm10793199