IBM Support

Making spell correction work on oneWEX Application Builder

Troubleshooting


Problem

When using oneWEX Application Builder to search a collection and type in a query with typo, Query Recommendation widget with Spell correction type won’t show anything.

Symptom

  • When using oneWEX Application Builder to search a collection and type in a query with typo, Query Recommendation widget with Spell correction type won’t show anything.
  • When you see the browser console, you will see HTTP Status 500 error.

 

Cause

The collection configuration is not properly reloaded.

Environment

  • oneWEX on Version 12.0.2 and Version 12.0.2.1. This would occur on both single container deployment and ICP deployment.
  • When you use both Search Input Widget (built-in) to create a search box and Query Recommendation Widget (built-in) with Spell correction type. Simply using the Search Input Widget only won't show the spell correction.

Resolving The Problem

Follow the steps below to work around the issue:

  1. Login to the oneWEX Admin Console, and select the collection in question.
  2. In the Fields section, once change the field type definition of any fields, and revert the change back to the original one, and save.
    Note: In this step, do not change the field definition indeed, but operate on UI once. Make sure to set the original configuration when you save.
  3. Exit the oneWEX Admin Console then confirm if Query Recommendation widget with Spell correction type would show the suggestion on oneWEX Application Builder.

Related Information

[{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SS8NLW","label":"IBM Watson Explorer"},"Component":"oneWEX","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"12.0.2;12.0.2.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
20 December 2018

UID

ibm10792253