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MustGather: Investigating error messages in Lifecycle Query Engine data source

Troubleshooting


Problem

What information you should collect to diagnose and resolve IBM Lifecycle Query Engine (LQE) issues when there are errors for processing data source.

Symptom

You see and error for resource in your LQE data sources page: https://your-server:port/lqe/web/admin/data-sources.

Cause

The errors are caused by returning any error message from LQE application. There are many reasons why they appeared. This MustGather will assist you in collecting the data necessary to help you diagnose and resolve the issue. If you are unable to determine the root cause using the information collected, you should open a support case for further investigation providing the data collected.

Resolving The Problem

The information below should be gathered:

  1. If you do not want to know the root cause of the issue, perform reindex of given data source. This often resolves the issue.
    NOTE: Reindex operation can take a long time, depending on data source type and repository size.
     
  2. Gather the log files according to Lifecycle Query Engine log files document.

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTU9C","label":"Jazz Reporting Service"},"Component":"Lifecycle Query Engine","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 February 2020

UID

ibm10791581