Troubleshooting
Problem
A CICSPlex SM (CPSM) address space (CMAS) goes short on storage (SOS) because it uses too much SMSHRC31 storage. This results in various types of messages including DFHSM0133, EYUPN0005W, EYUPN0005W, and EYUCL0117E.
Symptom
DFHSM0133 CICS is under stress (short on storage above 16MB).
EYUPN0005W Notify created for SAM, Sev=VHS, Event=!!SAMSTL, Text=IRLINK STALLED
EYUPN0005W Notify created for SAM, Sev=HW, Event=!!SAMTDM, Text=ID=AICA
EYUCL0117E Insufficient ECDSA storage to expand link buffer pool
Cause
Loss of communications to another CMAS
Diagnosing The Problem
CPSM stores the Method Argument List (MAL) control block and its associated data in the SMSHRC31 subpool. When you lose communication to another CMAS, the local CMAS still makes requests to send MALs to it. Large numbers of MALs cause the problem. They must wait for CICS to recover communication.
You need to determine who the partner is and recover communication to it. When you start communications to the other CMAS, the local CMAS removes them from the queue and storage.
MRO does not post a SEND until the data is completely transferred to the partner. Until then, control shows on the other side. To see if this is the case, check the MRO session's TCTTE for the TCTEIRCO bit. If this bit is on, it means that the local CMAS requested the send of the data. But the send is not yet complete. You need a dump of the other CMAS to determine why the data is not completely sent.
Resolving The Problem
Re-establish communication to the other CMAS.
Product Synonym
CICSPlex SM CICSPlexSM CPSM CP/SM
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Document Information
Modified date:
22 February 2023
UID
swg21178847