IBM Support

Registry errors occur when launching Rose RealTime on Windows 2000/XP

Troubleshooting


Problem

Error: "Failed to update the system registry. Please try using REGEDIT" occurs when launching Rose RealTime on Windows 2000/XP. This Technote discusses the symptoms for this problem, as well as the resolution.

Cause

The user has "Guest" or "User" privileges on Windows 2000/XP. "Guests" and "Users" do not have rights to update the system registry.

Resolving The Problem

Launching Rose RealTime on Windows 2000/XP causes the Error dialog: "Failed to update the system registry. Please try using REGEDIT. <OK>"

When you select "OK" the registry files for Rose RealTime are not updated correctly. As a result, you may see the following symptoms:

* The Model Browser and the Output window do not automatically appear in the Rose RealTime workspace.

* Two menu items: "Add Class Dependencies" and "Component Wizard" are missing from the Build menu.

* The configuration of the Add-In Manager is not restored, i.e. no checkmarks appear when Tools > Add-Ins is selected.

* The 'Version' and 'Company' data for add-ins do not appear in the 'About Rational Rose RealTime' dialog (Help > About Rational Rose RealTime). The 'Version' and 'Company' information only appears for "Rose RealTime".

* The toolset will not allow the user to set the 'Environment' and 'Type' fields in the General tab of the component specification.

* (Windows 2000:) The toolset will not allow the user to set the 'TargetConfiguration' on the C or C++ Compilation tab of the component specification. When the 'Select' button is clicked, the 'Select Target Configuration' dialog does not appear.

* (Windows 2000:) Attempting to build a model by selecting "Rebuild" in Build menu or by using the hammer icon in the toolbar causes a "Build failed" message in the Build Log.

* (Windows 2000:) Attempting to run a model after selecting "Yes" to the question: "Executable does not exist. Build it?" gives the Error: "Operation not allowed."


The above symptoms and error is caused when the user has "Guest" or "User" privileges on Windows 2000/XP. "Guests" and "Users" do not have rights to update the system registry.


To resolve this problem, attain "Power User" or "Administrator" privileges on Windows 2000/XP. For more information of how to attain these privileges, please refer to the Windows 2000/XP help.







Related Information

[{"Product":{"code":"SSSHKL","label":"Rational Rose RealTime"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2002.05.20;2003.06.00;2003.06.01;2003.06.12","Edition":"All Editions","Line of Business":{"code":"LOB45","label":"Automation"}}]

Historical Number

18529

Document Information

Modified date:
16 June 2018

UID

swg21125461