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Unable to configure ODBC driver <driver name> when trying to generate a new ODBC datasource in RequisitePro

Troubleshooting


Problem

This technote identifies a potential cause and resolution to the error Unable to configure ODBC driver , which might occur when generating a new ODBC datasource in IBM® Rational® RequisitePro® (ReqPro)

Symptom

The full error message is as follows:

Unable to configure ODBC driver <driver name>. The setup routines for the <driver name> could not be loaded due to system error code 126.

Cause

There are two possible causes for this problem. The first cause is incompatible .dll files. These problems may have occurred due to the installation of older software which changed the registry settings of the ODBC drivers or replaced some .dll files with incompatible versions. The second cause may be a result of Incorrect registry settings for MDAC components.

Resolving The Problem

If there are incompatible versions of .dll files, reinstall your current version of MDAC. The version of MDAC on the PC may be verified by executing the MDAC component checker. This utility may be obtained from Microsoft.


If there are incorrect registry settings for MDAC components, a user may experience problems when attempting to establish an ODBC connection through a datasource. The registry settings may be verified regedt32.exe. (i.e regedit or regedt32)

NOTE: This solution contains information about modifying the system registry. Before making any modifications to the Microsoft® Registry Editor, it is strongly recommended that you make a backup of the existing registry. For more information describing how to back up the registry, refer to the Microsoft Knowledge Base article 256986 http://support.microsoft.com/kb/256986.

Resolution for incorrect registry settings problem:

  1. Start Registry Editor (Regedt32.exe).
  2. Locate the following key in the registry:

    HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI


    Installation information for ODBC drivers is stored in this key. Make sure that all the required ODBC driver files are in the correct folder as described by the registry keys. RequisitePro may use one of the following three drivers, dependent upon the database type. The driver information is listed below for Microsoft Access, Microsoft SQL Server, and Oracle. Please note that the Microsoft ODBC driver for Oracle is referenced below, as this is the driver used by RequisitePro. Also note that the registry entries below will be variant depending upon operating system type, and install path. The registry listings below are for a default install of a Windows 2000 operating system.


    Access

    HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\Microsoft Access Driver (*.mdb)

    Driver = C:\WINNT\System32\Odbcjt32.dll
    Setup = C:\WINNT\System32\Odbcjt32.dll




    Oracle

    HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\Microsoft ODBC for Oracle

    Driver = C:\WINNT\System32\msorcl32.dll
    Setup = C:\WINNT\System32\msorcl32.dll




    Microsoft SQL Server

    HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\SQL Server

    Driver = C:\WINNT\System32\SQLSRV32.dll
    Setup = C:\WINNT\System32\SQLSRV32.dll



    This will cause an error if the Odbcjt32.dll file is in the C:\WINNT\System32 folder. The registry values may be modified to reflect:
    C:\WINNT\System32\odbcjt32.dll to solve this problem. Also verify that the Odbcinst.ini file has the correct entries in the same way.

    Any wrong value in HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI under the Setup key will cause this error.


    Please reference Microsoft Knowledge Base Article Q260558 for further information.

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Historical Number

111535864

Document Information

Modified date:
16 June 2018

UID

swg21119694