Troubleshooting
Problem
After a Windows 10 update, IBM i Access Client Solutions - Windows Application Package connections to the IBM i defined with "Use Windows user name and password, no prompting" (*WINLOGON) option to authenticate will fail with CWBSY1040.
Cause
Windows 10 updates sometimes delete the network provider settings registry tree:
This causes the IBM ACS Windows Application package software to fail to acquire the logged-on Windows user ID and password. Connections defined to "Use Windows user name and password, no prompting" will then fail with error CWBSY1040.
A specific key that the "Use Windows user name and password, no prompting" option relies on is:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Cwbnetnt
Resolving The Problem
There are currently two options to resolve:
1) Change the IBM i connection configuration from "Use Windows user named and password" to "Use Default user ID, prompt as needed"
This can be accomplished via the cwbcfg command from Windows command prompt:
C:\> cwbcfg /host <MyIBMiHostname> /uid <MyIBMiUserProfile> /r
Note - Replace the italicized values as appropriate. "/r" replaces existing configuration information
This will cause the specified IBMiUserProfile to be used for all connections where a USRPRF is not specified. The first connection will prompt for password. If successful, that password will be cached and used for subsequent connection attempts. The cache is cleared when the Windows user closes their Windows session.
2) Re-install IBM Access Client Solutions - Windows Application Package to recreate the needed registry keys.
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Document Information
Modified date:
18 December 2019
UID
ibm10731519