Troubleshooting
Problem
Failed to establish connections for ECS/ESA on IBM i V5R4 and V6R1 systems.
Symptom
Certificate errors would be posted on the ESA audit log (GO SERVICE option 14)
Cause
The periodic Call Home gateway servers require new certificates signed by DigiCert root certificate. Unfortunately, Electronic Service Agent on IBM i (iESA) doesn’t include DigiCert root certificate in its key store to communicate with the servers. This causes the failure of the handshake with the servers.
Resolving The Problem
Note: Both OS versions are currently out of support without a Extended Support Extension contract. And the problem mostly affect Inventory and PM transmission, so we handled as 'Best effort'. Information is provided 'as-is' Systems need to be current on PTFs. Below are the instructions to issue based on the Operating System.
- V5R4
Assure that the following PTFs are on system:
SI64307 (Need to be applied first. It requires 5722JV1 option 7 (JDK 1.5) to be on system prior to apply the PTF.
SI64316
SI64343
SI64345
After apply the PTFs, recreate the service configuration to assure that changes are taken. Steps provided in document N1010756: Configuration Instructions for Electronic Customer Support (ECS), Electronic Service Agent (ESA) and PM Agent for V5R4 and Higher releases (<--Link) .
Once the service configuration was created, the attached save file provide the new key stores including DigiCert root certificate. Run the following commands to transfer the file to system and restore the key store from the SAVF:
1. On IBM i create a SAVF:
CRTSAVF FILE(QGPL/UNIVCONN54)
2. Download the attached SAVF to your PC. i.e. C:\
3. From Windows Command Line (CMD) FTP to the IBM i server:
C:\ FTP 'xxx.xx.xx.xxx' where 'xxx.xx.xx.xxx' is the TCP/IP address of your IBM i or its system name. Then enter your user ID and password for the iSeries. This should get you signed on to the iSeries.
4. Now enter the following commands:
ftp> BIN
200 Representation type is binary IMAGE.
ftp> CD QGPL
250 "QGPL" is current library.
ftp> LCD C:\ <- use the directory where the SAVF was stored in your PC
Local directory now C:\
ftp> PUT UNIVCONN54.SAVF
Once the file has been moved over to the IBM i, enter the following command to close that process.
ftp> quit
5. Restore the file:
RST DEV('/QSYS.LIB/QGPL.LIB/UNIVCONN54.FILE') OBJ(('/QIBM/UserData/OS400/UniversalConnection'))
6. Give the authorizations needed:
CHGOWN OBJ('/QIBM/UserData/OS400/UniversalConnection/UNIVCONN.KDB') NEWOWN(QSYS)
CHGAUT OBJ('/QIBM/UserData/OS400/UniversalConnection/UNIVCONN.KDB') USER(*PUBLIC) DTAAUT(*EXCLUDE) OBJAUT(*NONE)
CHGAUT OBJ('/QIBM/UserData/OS400/UniversalConnection/UNIVCONN.KDB') USER(QSYS) DTAAUT(*RW)
- V6R1
Assure that the following PTF is on system:
SI55387
After apply the PTF, recreate the service configuration to assure that changes are taken. Steps provided in document N1010756: Configuration Instructions for Electronic Customer Support (ECS), Electronic Service Agent (ESA) and PM Agent for V5R4 and Higher releases
Once the service configuration was created, the attached save file provide the new key stores including DigiCert root certificate. Run the following commands to transfer the file to system and restore the key store from the SAVF:
1. On IBM i create a SAVF:
CRTSAVF FILE(QGPL/UNIVCONN61)
2. Download the attached SAVF to your PC. i.e. C:\
3. From Windows Command Line (CMD) FTP to the IBM i server:
C:\ FTP 'xxx.xx.xx.xxx' where 'xxx.xx.xx.xxx' is the TCP/IP address of your IBM i or its system name. Then enter your user ID and password for the iSeries. This should get you signed on to the iSeries.
4. Now enter the following commands:
ftp> BIN
200 Representation type is binary IMAGE.
ftp> CD QGPL
250 "QGPL" is current library.
ftp> LCD C:\ <- use the directory where the SAVF was stored in your PC
Local directory now C:\
ftp> PUT UNIVCONN61.SAVF
Once the file has been moved over to the IBM i, enter the following command to close that process.
ftp> quit
5. Restore the file:
RST DEV('/QSYS.LIB/QGPL.LIB/UNIVCONN61.FILE') OBJ(('/QIBM/UserData/OS400/UniversalConnection')) PVTAUT(*YES)
Was this topic helpful?
Document Information
Modified date:
18 December 2019
UID
ibm10730099