IBM Support

Security Bulletin: IBM QRadar SIEM contains Brotli components with known vulnerabilities

Security Bulletin


Summary

A buffer overflow vulnerability in the Brotli decoder was addressed in IBM QRadar SIEM

Vulnerability Details

CVEID:   CVE-2026-111497
DESCRIPTION:   A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream. Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.
CWE:   CWE-252: Unchecked Return Value
CVSS Source:   NVD
CVSS Base score:   9.8
CVSS Vector:   (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H)

Affected Products and Versions

Affected Product(s)Version(s)
QRadar7.5.0 - 7.5.0 UP16 IF02
QRadar7.6.0.0 - 7.6.0.6

Remediation/Fixes

IBM strongly encourages customers to update their systems promptly.

ProductVersionFix
IBM QRadar SIEM 7.5.07.5.0 UP16 IF03

 

Workarounds and Mitigations

QRadar Hotfix Installation Instructions

Customers who are unable to apply the above Remediation / Fix, or where a Remediation / Fix is not currently available for a given version, can apply the following HotFix where applicable.

Applies to:• QRadar versions 7.5.0 Update Pack 8 (UP8) and later OR 7.6.0.0 and later.

Important: Customers running in FIPS enabled mode should apply the workaround in https://www.ibm.com/mysupport/s/defect/aCIKe00000003a2OAA/dt395621?language=en_US to install this hotfix

Important Update: Customers who ran previous version of this install script may need to restart services to ensure this mitigation is fully applied. The installer now distributed in CVE-2026-11-05-111497.tgz will automatically restart required services, and can be run on systems that have already been mitigated to restart the required services. This new installer was published 2026-11-05 1800h UTC.

Installing the Hotfix1. Download the hotfix package (CVE-2026-11-05-111497.tgz) from IBM Fix Central.2. Copy the hotfix file to your QRadar Console to the /store/ibm_support/ directory and navigate to that directorycd /store/ibm_support/3. Extract the package:.tar -xzvf CVE-2026-11-05-111497.tgz4. Change to the extracted directory:cd CVE-2026-1114975. Install the hotfix by running:./install.sh6. The installer will report successful, or display an error detailing the issues encountered.

Additional Information• The installer automatically applies the hotfix to the Console and all managed hosts in the deployment.• No manual installation is required on managed hosts.

Upgrade ConsiderationsImportant: If you upgrade QRadar after applying this hotfix, the hotfix may be overwritten by the upgrade process. After the upgrade completes, reapply the hotfix to ensure the fix remains in place.

Get Notified about Future Security Bulletins

References

Off

Acknowledgement

Change History

04 Nov 2026: Initial Publication

*The CVSS Environment Score is customer environment specific and will ultimately impact the Overall CVSS Score. Customers can evaluate the impact of this vulnerability in their environments by accessing the links in the Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES ""AS IS"" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY. In addition to other efforts to address potential vulnerabilities, IBM periodically updates the record of components contained in our product offerings. As part of that effort, if IBM identifies previously unidentified packages in a product/service inventory, we address relevant vulnerabilities regardless of CVE date. Inclusion of an older CVEID does not demonstrate that the referenced product has been used by IBM since that date, nor that IBM was aware of a vulnerability as of that date. We are making clients aware of relevant vulnerabilities as we become aware of them. "Affected Products and Versions" referenced in IBM Security Bulletins are intended to be only products and versions that are supported by IBM and have not passed their end-of-support or warranty date. Thus, failure to reference unsupported or extended-support products and versions in this Security Bulletin does not constitute a determination by IBM that they are unaffected by the vulnerability. Reference to one or more unsupported versions in this Security Bulletin shall not create an obligation for IBM to provide fixes for any unsupported or extended-support products or versions.

Document Location

Worldwide

[{"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSBQAC","label":"IBM Security QRadar SIEM"},"Component":"","Platform":[{"code":"PF016","label":"Linux"}],"Version":"All","Edition":"","Line of Business":{"code":"LOB77","label":"Automation Platform"}}]

Document Information

Modified date:
05 November 2026

Initial Publish date:
04 November 2026

UID

ibm17295464