IBM Support

Access Client Solutions Font and Icons Show Blurry and Enlarged.

Troubleshooting


Problem

Scaling and Rendering of Font and Icons within Access Client Solutions may not show as desired. Font, menu options and icons seem enlarged, fuzzy and scaled improperly.

Cause

This behavior can be caused by Windows Scaling and High DPI display environment compatibilities.

Environment

IBM i Access Client Solutions Java Application on Windows

Diagnosing The Problem

Java 8 runtimes on Windows are not High DPI aware, but Java 11 and later runtimes are.

The IBM i Access Client Solutions executable acslaunch has not been coded to set any high dpi related settings because it is designed for Java 8 and higher, so the design is written for the lowest common denominator of Java 8.

So, when you are running IBM i ACS with Java 8, neither of them are interacting with the Windows high dpi capabilities.

But, when running with Java 11 and it's runtimes are now attempting to interact with Windows high dpi capabilities, but acslaunch is not, undesirable results can occur.

Resolving The Problem

Lowering the setting for display scaling to recommended or lower percentage can improve things significantly.

To further improve the display environment it is recommended to tell Windows to control the High DPI behavior of the IBM i Access Client Solutions acslaunch executable. 

The following Windows article shares multiple  different ways to edit the GDI and High-DPI settings.

- https://blogs.windows.com/buildingapps/2017/05/19/improving-high-dpi-experience-gdi-based-desktop-apps/

From this information do the following with IBM i Access Client Solutions.

Navigate to where IBM i Access Client Solutions is launching from.  This is the location the Target of the Desktop icon and will be something like:
C:\Users\<Wndows_User>\IBM\ClientSolutions\Start_Programs\Windows_x86-64

Right click on the application acslaunch_win-64.exe and select Properties

Go to the Compatibility tab, enable "Override High DPI scaling behavior" and set the Scaling Behavior to "System (Enhanced)".

Along with adjusting the Windows Environment and monitor settings, there are a few settings within the Access Client Solution Emulator that may assist. The following settings are found from the emulator window in Edit -> Preferences -> Appearance -> Font.

- Font Scaling is enabled by default and will present the screen text as a best full fit to the windows. Disabling Font Scaling may assist with blurriness, but will likely address orientation issues,  by no longer being scaled to fit the full screen.

- Antialiasing is another setting that can be toggled in attempt to make the text more clear. This setting adjusts the pixels to display differently that may present a clearer result. 

- Different Fonts may also assist with better clarity.

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Document Information

Modified date:
12 September 2024

UID

ibm10729339