IBM Support

Fix list for Informix Server 14.10.xC14 and Informix Client SDK 4.50.xC14 releases

Release Notes


Abstract

Informix provides periodic fixes for the 14.10/4.50 releases. The following list is the most recent report of defect fixes for customer-reported defects in the Informix Server 14.10.xC14 and Informix Client SDK 4.50.xC14 releases. This report combines both Windows and UNIX-specific defect fixes and is a summary of all fixes since the 14.10.xC13 release that are fixed in 14.10.xC14.

Content

Fix Pack 14.10.xC14/4.50.xC14
Fix release date: 20 August 2026
Download: IBM Fix Central

KI IDKnown Issue Abstract
IT46413SESSION HANG OR ASSERT FAILURE MAY OCCUR IF INSUFFICIENT RESOURCES AVAILABLE WHILST CREATING THREADS FOR PARALLEL INDEX BUILD
IT46162An insert statement on a table with TEXT or BYTE columns may create an orphaned BLOB or can assert when queried using a DB2 client.
IT46130ORPHANED TEMP PARTITIONS FROM A COLLECTION DERIVED TABLE INSIDE A STORED PROCEDURE COMPILED WITH NON-ZERO PDQPRIORITY
IT45946ROLLBACK EXCEPTION HANDLER WITH OPEN CURSOR RAISING ERROR 721 WITH A NON-EXISTENT UDR NAME
IT45841ASSERT FAILURE IN CHKDEFCON() ON LOOPBACK SERVER APPLY THREAD USING SPL AND VIOLATES CONSTRAINTS
IT45674CURRENT_ROLE RETURNS A DIFFERENT STRING/DIFFERENT CHARACTERS AFTER SETTING THE ROLE ON LINUX OS.
IT45658CREATING A FUNCTION WITH A LVARCHAR PARAMETER USING SQL_LOGICAL_CHAR AND UTF8 CAUSES PROBLEMS IN SCHEMA GENERATION
IT45430AF IN GENINTVLFRAGEXPR ON READ-ONLY SECONDARY WHILE RUNNING QUERY AGAINST TABLE BEING ALTERED
IT44942ONBAR -V MIGHT CORE DUMP IF BAR_NB_XPORT_COUNT IS A LARGE VALUE
IT44696APPROXIMATELY 109 ERROR MESSAGE DESCRIPTIONS ARE MISSING FROM THE FINDERR TOOL
IT44527INACCURATE DOCUMENTATION ON CONDITIONS FORCING DELUXE LOAD FROM EXTERNAL TABLE
IT44130ERROR 1213 IN REMOTE QUERY USING CONCAT
IT44074A "PUSHDATA RESET_CAPTURE" MIGHT SHOW "FAILED TO GET THE CONTROL BLOCK FOR MEASURING THE QUALITY OF REPLICATED DATA"
IT43757AUTOREG TASK SHOULD NOT RETURN AN ERROR WHEN ANSI DATABASE DOES NOT HAVE BLADES
IT38562CDR MIGRATE SERVER RESETS CURRENT SERIAL COLUMN VALUE IF NO ROWS WHILE MIGRATING / SYNCING
IT35233ERRORS REPORTED DOING PER DATABASE SQL COMPONENT CONVERSION SHOULD BE MORE INFORMATIVE
DT495598A dynamic hash join query using SUBSTR() in the filters will create an Assert Failed in fnsubstr().
DT474929A SELECT COUNT(*) query returns NULL for virtual columns in views created with UNION ALL.
DT474473Numerical output from the 'onstat -C' command can merge together when there are really large numbers.
DT474439Possible memory corruption and Assert Fail during cleanup of netscb.
DT474374Setup of HDR can fail with "DR: Failure recovery error (6)" when secondary is set up via oninit -PHY and BACKUP_FILTER/RESTORE_FILTER is used.
DT473786Signal 11 and crash in oncmsm as the result of suspected heap memory corruption.
DT473744DRDA can leak session memory for SQSCB when database name is >= 18 chars.
DT473363An error during a cloud restore of logical logs using a RESTORE_FILTER may be internally discarded, later resulting in an Assertion Failure.
DT472541Unable to restore critical files using onbar and onpsm when creating a new catalog using onpsm -O list.
DT472426After upgrading from earlier IDS 14.10 to newer 14.10, executing a stored procedure can fail with -1213 : A character-to-numeric conversion process failed.
DT471982With IFX_FOLDVIEW set to 1, a query may return the error '768: Internal error in routine opjoin().'
DT470376Loading data into a fragmented table using an external table in EXPRESS mode with PDQPRIORITY 10 causes an Assert Fail.
DT470269Error 768 occurred in wrtminibin() routine when running UPDATE STATISTICS on a temp table using a non-DBSA user with Connect/Resource privileges after in-place upgrade.
DT470259SSL connection from CSDK (using GSKIT) to HCL Informix (using OpenSSL 3.0) fails.
DT470053The optimizer is choosing a less efficient plan when the query filter includes datetime year to fraction.
DT469911Dropping a temp table with a blobspace blob column potentially causes extended critical section and checkpoint blocking.
DT468918Certain merge statements cause a persistent error -26918, after running for a certain number of iterations.
DT468679Unload of special characters (example: ä) from a varchar field and with conversion from 8859-1 to uf8 can truncate the text.
DT468416Suboptimal query plan with partial indexes.
DT468409Creating or rebuilding an index generates a data distribution, but because partial indexes omit certain values, an UPDATE STATISTICS HIGH or MEDIUM command is required to ensure the distribution includes all available column data.
DT468006Memory corruption can occur while selecting from some sysmaster tables, resulting in assertion failures with varying stack traces.
DT467829The actual password is displayed in the psm_act.log file after issuing `onpsm -D` to add a cloud device.
DT467376The cdr sync command fails with '-1215: Value exceeds limit of INTEGER precision' after values in replcheck_stat_tab or replcheck_stat_node exceed 2147483647.
DT466253The error -357 can be seen during a SELECT from a remote view.
DT465805A crash (SEGV) is possible in meRealloc() when there is 32-bit integer truncation of 64-bit pointers.
DT464522The wrong partition may be dropped when dropping a system generated temporary table.
DT464382Bad block header assert warnings and potentially other types of assertions.
DT464299Extending an sblob can fail to replay on secondary servers.
DT464032Update statistics high on fragmented temp table may fail with -768 mbmerge2bin error or error 312/100.
DT463729A crash is possible while parsing/constructing a complex or malformed query.
DT463494Deadlocks may be observed after long waits on the hash and lru mutexes.
DT462130Long server block time at start of level 1 archive may occur when large sbspaces are present.
DT461368Update Statistics run against a procedure can return the -705 error.
DT461246In a mixed environment with tenant and non-tenant databases, tasks from the sysadmin database may fail with "exceeded the session limit" for the informix user.
DT461067The CDR replay position won't advance while running an update on the source table which is not fully synced with target table.
DT461016When STMT_CACHE=2, dbschema induces 'Assert Failed: No Exception Handler'.
DT460899Creating the Java VM throws Assert Failed when JVPARGS is set.
DT460757After extending a temp dbspace chunk, oncheck -pe report wrong/old free pages on HDR/RSS.
DT459106Several menu keys are not working correctly in dbaccess on Windows.
DT458971Memory block header corruption detected by the pfsc_booster thread during startup.
DT458702A query with just the skip clause might not get a good plan.
DT458566The command 'cdr check replset' used with '--since' and '--repair' options will give incorrect values (mismatch/missing).
DT457498The 'onstat -g afr smartblob' command should show the originating location allocating the memory.
DT457496Stored Procedure Language (SPL) SELECT statement fails with Error -9635 when evaluating DECODE after the first field into a BOOLEAN variable.
DT457129Considering two tables populated with the same data but with different indexes; when executing the same query on both tables, the results varied. The expected outcome is that the results should be identical.
DT456892Running dbschema -d <databasename> -t all -ss <filename> with STMT_CACHE=2 generates errors: -959,-172, -25582, -349.
DT456590Updating BSON columns with ASCII characters above 127 may throw 959/172 error(s) a trigger an Assert Failure.
DT456203The dbload option -i, which specifies the number of rows to ignore in the input file, is not functioning correctly.
DT455110When btscanner invokes BTMERGE on a raw table index, the resulting BTMERGE log record triggers an assertion failure during log roll-forward.
DT454571When updating a page with outstanding in place alters after ALTER TABLE from char to varchar, errors with 'bfcheck bad page pg_frptr <size> < sizeof(ifx_page_t) 24 or > slotbeg <size>'.
DT453444An aborted dbexport command on an RSS may result in persistent errors when running onmode -wm STOP_APPLY=1.
DT453233Possible 'Assert Warning' logged while attempting to read rows with LC isolation level, if the rows are locked by particular a transaction.
DT446292Alter fragment on table <tab1> attach on fragmented table rebuilds all the existing index partitions.
DT436557The default SHMBASE address on Windows can lead to MapViewOfFileEx errors for onstat/oncheck when the size of shared memory is > 5GB.
DT435110The sysadmin "ADD LOG" task can produce the error "458: Long transaction aborted."
DT423212Select on a bson column throws error -937 "bson_to_char: mi_lo_to_buffer returned 8136, but the UDT had 8498 bytes".
DT423086The onsmsync utility does not delete entries for dropped dbspaces from the ixbar file along with deleting entries from the sysutils tables.
DT422432When the storage manager deletes a storage object corresponding to particular L0 object, on all subsequent runs of onsmsync it reports "Found a L1 backup object without an earlier L0. Removing it from the timeline."
DT420102Running the oncheck -cDI command against an HDR primary results in an Assert Warning if the table contains a mix of BTREE and BTS indexes.

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSGU8G","label":"Informix Servers"},"ARM Category":[{"code":"a8m500000008cqlAAA","label":"Informix Publications"}],"Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"14.10.0"}]

Document Information

Modified date:
27 August 2026

UID

ibm17285388