Troubleshooting
Problem
After retraining a model in Manage, the model ready flag is false even though predictor pod is running fine.
Customers will not be able to use the model after retrain since the inference request is sent only after the ready flag is set to true which in case of retrain will always be set to false.
Symptom
After customer retrains the model in Manage, model ready flag is false in Manage's AI Config page.
Customers will not be able to use the model after retrain because the inference request is sent only after the ready flag is set to true which in case of retrain will always be set to false.
Cause
After customer retrains the model in Manage, a new predictor pod is created in AI Service. Once the new pod is ready, the old predictor pod is deleted from the namespace. AI Service KMODEL Controller receives that deleted event and treats that event as deleting the primary predictor pod and sets the ready flag to false.
Environment
Maximo AI Service
Openshift cluster
Diagnosing The Problem
After a customer retrains the model in Manage, the model ready flag is false in Manage's AI Config page.
Resolving The Problem
Customers will need to manually login to the OpenShift admin web console and go to the tenant namespace. Then restart predictor pod for that model to force update ready flag. You can even re-create model with same configuration rather than retraining in Manage.
For further assistance, contact IBM Support.
Document Location
Worldwide
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Document Information
Modified date:
25 June 2026
UID
ibm17275977