Troubleshooting
Problem
On Windows, when IBM Support Assistant Team Server is installed on a drive other than C then Memory Analyzer [Report] fails to run.
Symptom
The Reports tab shows that Memory Analyzer [Report] failed during execution. When clicking on the report name, the panel where the report would appear instead displays the following message.
The tool failed to complete, therefore there is no report to preview. Click on the toolbar action 'Go to the Report Directory in Files View' to review the contents of the output report directory.
Cause
The problem occurs because IBM Support Assistant Team Server incorrectly tells Memory Analyzer that its temporary storage is located on drive C.
Diagnosing The Problem
Follow the instructions in the error message to open the Report Directory in the Files view. You should see a log named t<time_stamp>-err.log. Double-click the log file name to open it in a new browser tab. Scroll to the bottom where a message similar to the following is displayed.
BUILD FAILED
Basedir Z:\Users\isa5\AppData\Local\Temp\com.ibm.java.diagnostics.memory.analyzer-t0126.130316.328660.d\work does not exist
Resolving The Problem
Work around the problem by setting the TMPDIR_PATH property to a location that's on the same drive as IBM Support Assistant Team Server. For this example, let's use drive Z. Follow these steps.
1. Create a temporary directory on drive Z (for example, Z:\tmp).
2. Edit <ISA_install_dir>\ISA5\isa.properties.
3. Add a line with "TMPDIR_PATH=Z\:\\tmp". (Note that you need to escape the colon and backslash characters with a backslash.)
4. Save isa.properties.
5. Restart IBM Support Assistant Team Server.
Related Information
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Document Information
Modified date:
10 September 2018
UID
swg21695394