IBM Support

Case-init job fails after upgrading to CP4BA 24.0.0 IF009

Troubleshooting


Problem

When you upgrade IBM Cloud Pak for Business Automation (CP4BA) or IBM Business Automation Workflow on Containers from version 21.0.3 IF039 to CP4BA 24.0.0 IF009, the case-init job does not complete successfully. This results in errors when you open Navigator desktop URLs.

Symptom

The case-init pod does not complete successfully, and the Navigator desktop URLs do not open properly.

Cause

The case-init pod log file shows java.lang.NoClassDefFoundError for com/ibm/bpm/icn/WorkDashboardFeature.

[4/27/26, 13:42:07:455 UTC] 00004b03 SystemErr                                                    R [04/27/26 13:42:07:453 UTC] 00004b03 SystemOut O CIWEB Error: [p8admin@10.254.12.141] com.ibm.ecm.util.PluginUtil.getPluginFeatures() Error retrieving the features for plugin: IbmbpmNavigatorPlugin
java.lang.NoClassDefFoundError: com/ibm/bpm/icn/WorkDashboardFeature
        at com.ibm.bpm.icn.IbmbpmNavigatorPlugin.getFeatures(Unknown Source)
        at com.ibm.ecm.util.PluginUtil.getPluginFeatures(PluginUtil.java:919)
        at com.ibm.ecm.mediator.DesktopMediator.toJSONObject(DesktopMediator.java:944)
        at com.ibm.ecm.mediator.BaseMediator.writeJSONResponse(BaseMediator.java:675)
        at com.ibm.ecm.struts.actions.BaseAction.writeJSONMediator(BaseAction.java:411)
        at com.ibm.ecm.struts.actions.BaseActionHandlerImpl.executeAction(BaseActionHandlerImpl.java:548)
        at com.ibm.ecm.struts.actions.BaseAction.execute(BaseAction.java:76)
        at com.ibm.ecm.jaxrs.Actions.doExecute(Actions.java:1025)
        at com.ibm.ecm.jaxrs.Actions.loadAndExecuteAction(Actions.java:989)

Environment

IBM Cloud Pak for Business Automation 21.0.3 IF039 upgraded to version 24.0.0-IF009.

Diagnosing The Problem

After upgrading, the case-init Pod does not complete successfully and the Navigator URLs are broken.

Resolving The Problem

  1. Delete the Navigator pod (navigator-deploy) to trigger reconciliation.
  2. After the Navigator pod restarts, verify that the Navigator desktop URLs are working properly.
  3. Start the case-init pod again.

The case-init pod completes successfully. After the Navigator URLs are accessible, the case-init pod reconciles automatically without manual intervention.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB76","label":"Data Platform"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSBYVB","label":"IBM Cloud Pak for Business Automation"},"ARM Category":[{"code":"a8m3p000000F91fAAC","label":"Operate-\u003EBAW Install\\Upgrade\\Setup-\u003EBAW Case Manager-\u003ECase Init Job"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"24.0.0"}]

Product Synonym

CP4BA

Document Information

Modified date:
08 May 2026

UID

ibm17272422